1

I'm using an USB audio interface (Roland Rubix 22) and its ASIO driver in Reaper (it's selected in Preferences > Audio > Device).

I wanted to have Reaper's output sent to the Realtek card from my laptop (so that the sound comes from the laptop speakers), but Reaper only shows as options for me the outputs of the audio interface.

Question: is it possible to select an audio device for ASIO driver in Reaper but have the output sent to another device (in my case, to my laptop speakers, instead of the outputs from the audio interface, used for the ASIO driver)?
I tried using the Routing Matrix and Rearoute but couldn't find such an option there.

Thanks!

Setup: Reaper 5 64 bit, Win 10, Roland Rubix 22

1

Hmm. Not sure you can do this under windows. With OSX it would be easy as you would create an "aggregate" device which includes both of these two hardware options and then you can route directly from reaper through the aggregate device to the required hardware output.

Unless Windows has the option of creating a 'virtual' or 'aggregate' device, I fear you will be unable to do what you seek.

  • Thanks! As far as I know, there's some software called Virtual Audio Cables for Windows, but it's paid and I don't want get it just for this. Other than this, Windows doesn't reroute the signals. I was hoping Reaper could allow me to this, I don't know why this option is not available – flen Apr 21 at 4:41
  • 1
    It was just never a considered use case when MS designed the audio subsystems in Windows. If you can find some powered speakers and connect them to the output on the external device (Rubix), then you should be good. – Mark Apr 21 at 4:59
  • 1
    Win10 now has selectable outputs per app, though I'm on Mac too so I've never seen it in action; & idk if it will work with ASIO - see howtogeek.com/352787/… – Tetsujin Apr 21 at 7:03
1

ASIO bypasses the Windows audio interface to connect the DAW straight to the sound card; so selecting that as your audio system will not allow you to bypass and use it at the same time. You can try to set it to WASAPI and see. I don’t use Reaper though.

  • Thanks! I think you're right, there's no Windows way to do it, I was hoping that Reaper had an option for it, but apparently it doesn't – flen Apr 27 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.