2

I am using Reaper on an HP laptop running Windows 7. The soundcard is integrated with the motherboard and I am using Asio4All to avoid latency issues.

On my old PC running Windows XP, I would often play jam tracks from my browser (Google Chrome), while jamming to the track with my guitar using effects through Reaper, all through my headphones.

On my current PC (described in first paragraph), I am experiencing an issue where if I try to do the same, audio from Reaper is played through the headphones, but the sound from my browser gets "bumped" to my laptop's speakers.

Can anyone shed some light as to why this is happening and how it would be possible to rectify the situation?

migrated from avp.stackexchange.com Jan 27 '14 at 15:14

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

  • Configuration - you need to ensure your sound config is set to play everything through headphones. Not sure whether this should be in Windows or Reaper config, otherwise I'd have posted as an answer. – Rory Alsop Aug 31 '12 at 0:28
1

This answer worked for me (windows 10). I haven't yet tested it on a heavy project, but it's enough to get other audio inputs like a browser to be audible.

I believe that the asio4all driver can only play sound from one application at a time. ... However there is a simple answer if you just want to play youtube videos and play along with reaper at the same time. In reaper/preferences/audio/device change the audio system from asio to one of the other choices. Thats what i do, i dont need super low latency for just following along with tutorial videos.

Source: https://forum.cockos.com/archive/index.php/t-100336.html from Rodal

1

I have two playback devices in my notebook, one's called something like "Speakers and Headphones", the other one's called "Communication-Headphones". I'd try to completely disable the second one, worked nicely for me and could maybe work for you. Another possibility is to get a decent audio interface ;)

1

Advanced software in Windows 7 is able to specify the playback device to use and thus will get routed based on a choice. Any software that is not able to choose a device on it's own will automatically be routed to the default audio device according to the options under Sounds in Control Panel.

If you update the default sound device to be the headphones and then restart the browser, it should play how you want.

1

I know this is a little late to post but I couldn't find a comprehensive answer for this question anywhere else online. So, I'm posting what worked for me here.

Okay this is how I setup my system so that everything plays through a single device and background sounds like YouTube or MP3s are able to play while Reaper is running.

This worked for me on both my HP Omen using Windows 10 and my HP EliteBook using Windows 7.

You should be able to go into your playback devices and set a default device. Then disable all other devices you do not want to use. This should force Windows to play everything through your desired device.

This for some (if you're using ASIO), will also block background application sounds (Youtube, Chrome, and alike) while Reaper is running.

In my case the way to fix this is to right click your newly selected default device and click Properties. From there you will need to go into the Advanced tab and drop your default format to CD or DVD quality. For me, this allows background applications to play sounds while Reaper is open. For when you want to jam with a song on YouTube or something.

Lowering the default format may very slightly lower the overall sound quality of your machine. I can barely even notice but I suggest when you go to record or when you're not using Reaper, you revert to a higher quality format.

I hope this is some use to some of you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.