0

Sometimes I record and monitor music with an ASIO device like Focusrite or Behringer XR18 and sometimes it's just me and my laptop and I want to work using the sound card at hand, in this case Realtek in an HP Envy running Windows 11. But when I switch from ASIO to WASAPI, the sound just vanishes and I get the "[audio device closed]" message, no matter what I try.

I've looked at the routing and I've adjusted the Windows 11 sound control source but all my projects will refuse to play. When I do get them to play, no sound emerges. But sometimes, sometimes it plays just fine. It's driving me crazy. Is there some protocol I should use when I switch between ASIO and WASAPI?

I'm so desperate, I've even tried to install a Realtek ASIO driver from the Microsoft Update Catalog at https://www.catalog.update.microsoft.com/Search.aspx?q=realtek%20asio but that dead-ended too because

dism /online /add-package /packagepath:{CAB file name}

fails.

1 Answer 1

0

The solution that finally worked for me was to install the Steinberg ASIO driver and use that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.