0

Everything worked fine - I recorded, mixed and just listened (youtube, soundcloud) through my audio interface M-audio M-track II - until, suddenly, it stopped working.

What exactly happened?

1) It's lights are still glowing, and it's showing up in "device manager"

2) It doesn't show up in audio devices (so I can't choose it as my main driver and use it)

3) In DAW (Ableton Live) I can't choose it as my audio device - it says "failed to open M-Audio M-Track ASIO (64)"

I tried restarting PC, changing usb ports, updating driver trough device manager (it's up to date), turning different knobs up and down

What else can be done to fix this?

UPDATE: I tried removing driver - and it showed up in playback devices, so I can now listen through it! Well, but no ASIO driver, which means that I can't make music properly.. when I install driver again, it's the same problem I described above

  • Had you updated the driver or windows recently before it all went wrong? – Simon Bosley Sep 8 '16 at 10:18
3

I had the same problem with my Mbox 3 pro, and concluded that there's a conflict between drivers when you use your interface for both windows and your DAW. Install the original drivers, try disabling your sound card as the default audio device in Windows (just let the Windows sound card as your default one) and use it only with your DAW.

  • Thank's for reply, I'll mark your answer as the best. I already fixed my problem - It just needed complete removal of: windows driver (which installs when you plug-in a device for 1st time) and ASIO driver (from interface manufacturer webpage), and doing a fresh install like it's used for the 1st time. I use my M-Track II with both windows and DAW at the same time with no problems, but I will remember your advice if there is any conflict – Darek Buryński Sep 8 '16 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.