I bought the Lexicon Omega to use as my mixer (primary soundcard) with my PC running Windows 7.

At my desk, I need to use the Lexicon Omega as my primary soundcard to connect PC sound to my speakers, and to control Cubase and Reason rewired, Sound Forge, Skype, Youtube, Gtalk, and often many of these at the same time.

The problem is I want to send ALL the audio to Lexicon, and many times two or more applications start a conflict.

I have the PC USB connected to Omega USB. I go to Sounds And Audio devices in Windows 7 Control Panel and I have to set the Lexicon to the default playback device and default recording device. Here are my options:


  • AMD HDMI Output - 2 AMD High Definition Audio Device:not connected
  • Speakers 2-USB Audio Device:Ready (Lexicon)
  • Speakers 4-USB Audio Device:Ready (Lexicon)
  • Speakers 5-USB Audio Device:Default Device (Lexicon)
  • Speakers-VIA High Definition Audio: Default Communication Device
  • SPDIF Interface (TX0)-VIA High Definition Audio: Ready


  • Lexicon Win USB 3-4 In Only - 2-USB Audio Device: Default Device
  • Lexicon Mac USB - 4-USB Audio Device: currently unavailable
  • Lexicon Win USB 1-2 In/out 5-USB Audio Device:unavailable
  • Microphone VIA High Definition Audio: Not connected
  • Audio CD - VIA High Definition Audio: Not connected
  • Line In - VIA High Definition Audio: Not connected
  • Stereo MIX - VIA High Def Audio: Ready

Which one should I choose?

I have installed the latest drivers version (ASIO Omega drivers).

Does anyone have any ideas on how to make this work? I've tried everything my meager experience and knowledge can come up with.

  • How many items are listed under playback and recording for your device? For instance, my firewire interface shows up only once for each as "Multichannel" with the model name underneath. Feb 10, 2012 at 21:37
  • 1
    I edited the question to add in the additional info in your comments. Please check to see that I got everything right and edit anything that is wrong or missing. Feb 12, 2012 at 4:29
  • Have you tried looking under the settings of both the software and the device settings for a check box that says something like "Allow applications to take exclusive control" ? For the device in the "sound" window <playback devices> - right click the one you want choose properties then under the advanced tab uncheck the Allow option. This may cause problems with some software that demands exclusive mode but from what I recall most software also has a setting that will turn it off with possibly just a warning about possible latency issues. Jun 29, 2015 at 0:02

1 Answer 1


I have a M-Audio Firewire interface which only has 1 entry each for Playback and Recording. I have it selected for playback and my regular sound card's microphone selected for recording. In my DAW, I use the ASIO driver to connect to the interface for both recording and playback. I can be playing back through the DAW and another application and hear both just fine. You should be able to do the same, we just need to figure out which device selection is correct.

I'm not sure why the Lexicon is showing up with three entries for each. For Playback, I would guess that the speakers 2 entry is probably the right one for stereo output.

For the recording device, I would set it to the Microphone on your built in sound card (VIA) since you will probably be using that for Skype.

Your DAW will be able to use the ASIO drivers for both recording and playback and should not interfere with anything else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.