1

hi,

i have the following setup:

Macbook Pro -> connected to WD Harddrive via Firewire -> daisy-chained to a firewire sound card -> connected to studio monitors / final output.

it worked fine for a while, but recently i have experienced weird things while playing back audio such as sudden mutes and distortions. i think it has something to do with the WD going to sleep mode after a certain time. i'm generally wondering if this connection setup / routing is healthy for the equipment?

3

Move the HDD over to USB. Firewire is good on spec but in reality chaining devices just doesn't seem to work as flawlessly as it should. Any device throwing junk out there on the bus can cause disruption to the entire chain and WD hard drives seem to be of those (I own one, it had this same problem). The cost of this solution is that the HDD will become slightly slower and less responsive but it's a small price to pay for getting back your audio interface.

  • I concur. I do believe when you daisy chain, you share/split the bandwidth of the single port, and depending on the demand of the individual devices in the chain, it will probably give the devices power issues that will cause them to react slower and have hiccups. If your MBP has an express card slot, get a firewire express card for that slot and you'll be able to connect the devices individually. If you don't then USB is the way to go. – user6513 Sep 19 '11 at 15:09
  • Firewire has better traffic management, but is far away from the speed of express card (fast becoming obsolete) for which the best thing is an express card interface. in PCIE mode, EC is the closest to good ol' PCI you can get on a laptop, and, meaning it's a synchronous bus, it can have crazy low latencies and generally works great for realtime devices (e.g. soundcards). that said... USB. – georgi Sep 19 '11 at 20:10
1

try flip the HDD and interface?

1

I would do as @Jamie Famularo says and connect first to the interface, then to the HDD. I'm not sure if anybody's had a lot of good or bad experiences with other hard drive brands, but WD drives always flip out on me. Sometimes they don't even mount for days at a time, for no reason.

That said, I sometimes experience problems booting my audio interface (MOTU 828mkII via FW400) if the HDD is connected to it; unplug it and it initialises just fine. The reason for this, I am led to believe, is the dynamic manner in which Firewire issues interrupts and the like; something which we used to do manually with serial ports. If anybody has any hard and fast rules for resolving Firewire device conflicts, by all means share them!

  • wish i could flip the HDD and the interface but unfortunately my interface has one firewire port only :-( – kampana Sep 15 '11 at 9:59
  • Well, crap... there's a solution for that. goo.gl/eYvdm – Dave Matney Sep 15 '11 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.