Edit: Well here's a sneaky preview of one of the many jet/prop plane recordings I managed to save! ;)


Just spent the whole day at an Air Show. Had a Nagra LB and a Sennhesier 418 (hired). Got loads of great sounds. Spitfires, various jets etc. Sounded cool when I checked the files over my headphones while I was there.

So got home all excited. Attached the USB cable to my Mac and connected the Nagra. Thought I'd see a whole host of Wav files come up, but instead saw jibberish. Turned back on the Nagra to check again and now it wont access the files!! Says Database Sync Error. It seems to quickly flick through the list of files I recorded but doesnt let me play them, as it previously let me. Really, really annoyed.

Anyone have a clue how to recover or save data from a Compact Flash card? Was a Sandisk Extreme if thats of any use :(



Thanks for all the suggestions guys! Managed to save almost all of it with the help of Sandisk RescuePro. Very useful little proggy!

  • Sorry to hear about that, man. Maybe try this Idiot Check #1: Did the card accidentally get switched to "Lock"? – Utopia Aug 20 '11 at 19:15
  • 1
    Nope, I checked. Unfortunately it seems to have thrown the mother of all tantrums and refused to be read whatever I try. Was feeling really pissed off until I found out one of the pilots died today. Puts it all in perspective! At least I'll have the luxury to be able to go back tomorrow to try again....RIP Red 4 :( – Andy Lewis Aug 20 '11 at 19:30
  • Now that you've saved it, let's hear a few examples! It seems like some great material, from your description. – Miles B. Aug 21 '11 at 19:04
  • The Nagra LB is renowned for that! Sorry you had issues. Glad you got most of it back. – Andrew Spitz Aug 21 '11 at 21:03
  • Have you heard that before about it then? Really surprises me if thats the case. I really liked using it but if I were to get the same problems consistently I'd not want to buy one :/ Of course I'd still love one for free :p – Andy Lewis Aug 22 '11 at 12:07

Don't do anything else to the card, something has been overwritten in the table of contents TOC, the data is probably still there.

The free version of Sandisk's RescuePro will tell you if the files can be recovered.


If it works the license is £30 for one year.

If it doesn't work there is a form to contact San Disk for further solutions.

If you can try, using a compact flash card reader connected directly to your computer to remove the variable of the recorder.

  • @Iain, I'd like to react to your statement not to do anything to the card. I reckon that if you're ever able to read something from the card, then the first thing you'd do is copy what you can. All I wish to point out is that every time you read data from a disk might be the last time anything can be read off the device, so you might just as well keep a copy of what's readable. Regards. – Justin Huss Aug 20 '11 at 23:51
  • I hope my comment doesn't sound rude, the website is misbehaving on my phone and I can't copy my text to edit it... – Justin Huss Aug 20 '11 at 23:56
  • Thanks Iain! Instead of trying to repair it with the card in the Nagra I put it in my card reader then with the help of RescuePro got nearly it all back. There are a couple of filed that have white noise on during the middle, but the rest were rescued. Got a load more recording done today too so now have plenty to edit. Just a shame it wad so hard to get anywhere without an annoying PA blaring! lol Thanks again :) – Andy Lewis Aug 21 '11 at 18:02

I'd switch to command line rather than relying on the Finder (I take it you're using a Mac because you're into sound, it's only a guess from personal statistics, I'm not categorizing or anything).

Use your terminal, navigate to /Volumes/ using

cd /Volumes/<disk name>

Type ls and press enter (it's short for list, it'll list the files it finds in the directory you're currently in, normally <disk name>) and hopefully you'll see something, maybe not a file list, but at least you'll manage to read bytes. I'd then try several manipulations:

  • In the case you see files, type:

Do the following:

mkdir ~/Desktop/save/ #this will create a folder named `save` on your desktop    
mv * ~/Desktop/save/ #this will move all the files it finds in the current directory to the `save` directory you just created on your desktop

  • In the case you don't see any file, I'm not quite sure what it'd look like, so I'd suggest you create an image of your flash card using Disk Utility (select your drive in the column on the left hand side and hit New Image in the tool bar at the top I believe) and send it someone's/my way if you're comfortable with this. Someone/I can have a look and hopefully find the problem/solution.

Alternatively, use Disk Utility to find the ID of your device: in the left hand side column click the disk (not the partition inside it, but the disk itself) and click Info in the toolbar at the top. The Disk Identifier looks something like disk1.

Then, in your terminal, type:

dd if=/dev/<disk ID> of=~/Desktop/save.img #this copies the byte sequence of the drive, it effectively makes a backup of it.

Maybe I haven't got my head round the issue just yet, so please don't hesitate to pick my brain if you think you might make progress with a little push.

Hope it helps and you get everything back!


I've had luck running TechTools on drives, although I've never tried it on an SD card. Principle should be the same though.


This worked for me. It can get from easy and quick to advanced and slow very quickly.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.