0

Hi,

when working on sound design for video in Logic 9, i use a project template with a sampling rate set at 48000khz. the source material i use vary in sample rate, hence i need to convert it all to 48000khz to match the project sample rate. up until now, what i always did, was to use an external batch audio processing tool (such as the great Sample Manager by Audiofile Engineering) to quickly convert all my material to the desired sample rate. recently switched back to Logic as my main DAW, i wanted to let Logic take care of sample rate conversions when necessary. so, i set my project preferences to include audio assests, copy all used audio files to project folder, etc. and automatically convert sample rates when there's no match. this seems to work properly, however, Logic's conversion also seem to pitch shift (more than slightly) my original material - which never happens when i use an external conversion utility (i usually need to convert from 44100khz to 48000khz). why is that?

say i turn off the auto conversion thingie and import material in different sample rates into the project while working, then export it all at 48000khz. will i have the same pitch-shifted artefact?

thanks

0

It is because logic tries to fit as many 'bits' of sound as possible into the space which the lower sample rate has. The lower rate moved up to higher sample rate will mean that logic will pretty much speed up the original file to fill in the space of the 44100 rate. Kinda hard to explain.

Keep the sample rates to the original size/rate then when bouncing the file down select dither (dosnt matter which type of dither... does all the same thing pretty much) and that should enable you to have a mix of all rates without pitch shifting.

Twitter @nialldalton

  • @Niall I might have misunderstood what you are saying, but what has bit depth got to do with pitch/speed/sample rate? Bit depth only relates to dynamic range – ntkeep Jun 6 '11 at 13:55
  • Yeah, bit depth dithering wouldn't have anything to do with it. See @Michael Manzke 's answer - it will fix your problem – Colin Hart Jun 6 '11 at 15:17
3

When you import a sample with a different samplerate via drag-and-drop Logic usually converts the file to the corresponding samplerate. However if you import for example a 44.1kHz file into a 44.1kHz session and set the samplerate AFTER this to 48kHz, your 44.1kHz sample won't be converted to 48kHz. This is when it will play back at a wrong speed/tone.

If you press 'b' you'll see on the right side what samplerate each sample has, if everything is set to the right samplerate it should sound correct.

  • this is correct – Colin Hart Jun 6 '11 at 14:47
0

This is odd. In all these years of using Logic I've never faced this problem. The only time it plays files at the wrong pitch and speed is when it doesn't convert on import (tends to do that with MP3s even if include/convert all assets is enabled). Could you post clips of the actual and converted file so we can get an idea of what the problem is?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.