1

First, I apologize if this is too vague a question for this group -- I'm perplexed and I don't have much data to work with. I think it's probably impossible to solve, given the limited data, but I just wanted to see if anyone had any ideas. Also if there's something I should watch out for if it happens again, so that I can have better data to track down any issue.

I have a studio setup with modular synthesizers running into an RME UFX II which is also connected to a pair of Yamaha HS 8 studio monitors. I record using Logic Pro X on a somewhat old MacBook Pro (running the latest system). The electrical lines were checked when I moved in, all are correctly grounded. Power is run through a Furman power conditioner before it reaches the equipment.

I was playing back in Logic something I had just recorded and listening to it through the studio monitors. Suddenly there was a really loud POP through the studio monitors and the playback sound cut out. I can't remember whether the UFX II showed anything on its LED interface -- I was kind of shocked and trying to shut things down -- but it seemed to me that it still had a couple of bars lit.

I quickly lowered the volume on the UFX II, in case there were any more pops (there weren't) and stopped Logic playback. I tried playing Logic again, but no sound came out. I quit Logic and started it back up and everything worked normally. I shut down the entire system and then started it up again (I didn't reboot the Mac, though) and all seems fine.

I know this is a long shot, but where would I start looking to try to determine what happened? Hopefully it's nothing with the UFX II -- it's only about a year old, so no idea why there would be a problem. The Mac has about 7 GB worth of free space, which I know is very little. Perhaps it's something with Logic? I believe I have the buffers set to 512MB, for whatever that's worth.

I've been using this setup for a year or so with no issues. I did have another issue earlier today: when I started everything up, I couldn't get any playback sound from Logic through the monitors: just a lot of scratchy sounds. I had only 200MB of free disc space on the Mac, so figured that might be the issue. I rebooted the Mac and cleared off about 7GB of space and it worked fine, until the events described above.

Also, FWIW, I know this kind of popping is bad for the monitors -- nothing I can do about it now. But I suppose I'd notice it if it had done any damage, right?

Thanks for any info!

Edit: one thing I thought of, when I cleared off disco space, I erased some caches and application support files from my /Library, but nothing to do with Logic as far as I know.

4
  • Are you using the latest driver for your audio interface?
    – htor
    Nov 4, 2023 at 1:07
  • I believe so. I don’t believe the OS has changed since I installed the driver originally. But I’ll look into it
    – Cerulean
    Nov 4, 2023 at 1:34
  • 1
    That sounds like a driver (/audio control software) hiccup to me, because audio from Logic stopped at the pop. But I don't do Apple, so can't help further. If it was a drive space issue, I think it would be reproducible, and you'd get a warning of some sort.
    – n00dles
    Nov 6, 2023 at 19:03
  • 1
    So far so good. RME say that it’s unlikely to be a hardware issue. I’ve updated the drivers, so we will see…
    – Cerulean
    Nov 7, 2023 at 14:17

1 Answer 1

3

Some musings… though whether this will lead to a 'fix' I'm not so certain.

Because the monitors are internally amped, any pop/click sent to them at full line level will nail you to the back wall. It may also cause any internal protection circuitry to momentarily activate. I have a pair of dynaudios that really don't like it if I forget to switch them off before I power down or reboot my Mac. The pop my interface sends as it power-cycles is damned LOUD. Having said that, I've done it accidentally maybe a couple of dozen times over the decade I've owned them, & they're still fine, so other than for your ears, I wouldn't worry too much.

My bet is the pop came from the interface - but how is where I don't really have a good guess, just some theory.

One possibility is your drive space - bear with me. 7GB free space is still critically low. Bear in mind that as free space has to take your Time Machine local snapshots and be your swap space for virtual memory, you can see why you need considerably more space. Rule of thumb for a drive is 10-15%, but ironically, much more on a small drive - so if you're stuck with one of those weeny 128GB drives they used to fool people into buying, you really need a good 20GB free at all times.
Also read/write on a full disk can get really slow, sometimes forcing the drive firmware to have to erase sectors before it can write, because TRIM hasn't time to keep up. You also see something akin to the effect of fragmentation that used to plague HDs, as smaller & smaller areas are left to read/write. SSDs still suffer from random read slowdown, sometimes dropping them on a full drive right down to HD speeds.
You can test this with Blackmagic Disk Speed Test - free from the App store.

A theory could be that your pop could have been caused by a huge wait queue during playback as the drive was struggling to keep up, perhaps even leading to momentary driver time-out.

Anyway, I can't point right at a cause, but hopefully there's something to get you looking in the right direction.

4
  • Thanks! When you say “interface”, what do you mean? The UFX II? Hopefully not, as that would be very problematic. I suspect (hope?) that it is indeed something in the software side. I’ll try to clear off some space. It’s really tricky since the Mac is 8 years old and as such did indeed come with a pretty small HD (either 128 or 256GB, I don’t recall at the moment) and when you’re working with Logic, and have a back catalogue of music, it fills up fast.
    – Cerulean
    Nov 4, 2023 at 11:58
  • 1
    Yeah - that's why I still have a building full of old 'cheesegrater' Mac Pros… full of drives. I've 17TB in this one right now, 2x1TB SSDs & the rest in HD. I do suspect it's the RME making the noise, but not necessarily the root cause of it. btw, there was new firmware & MacOS drivers released 15 Oct - certainly worth a try - rme-audio.de/fireface-ufx-ii.html
    – Tetsujin
    Nov 4, 2023 at 12:09
  • Thanks. I’ve cleared off 30Gb of the 256 internal. Can do 40 more if necessary. — do you think there might be a hardware issue with the RME? I can contact them (it’s under warranty in any case). I’m installing the kernel extension and driver updates from the UFX II page (both from May), and did the “Flash” update (from October)
    – Cerulean
    Nov 4, 2023 at 12:53
  • 1
    See what happens after the updates. It's always worth asking them if they have any similar experience.
    – Tetsujin
    Nov 4, 2023 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.