0

I've bought a Douk U2. I've connected it to my mac mini via usb and I use the optical out to connect it to my speakers.

This is my first time using optical/toslink so I'm not sure what the issue might be.

When I fully plug the toslink cable into the U2, I don't get any sound. If I only plug it in halfway, I get audio.

How can this be?

edit: It gets even better. It works flawlessly on windows. This is a mac only problem. How is this possible? Macos should only see the usb device, it shouldn't even register that something is plugged into the optical out of the usb device.

Thanks.

0

1 Answer 1

1

My guess would be that the sender/receiver LED is likely misaligned with the socket, or the plug is bent so that you need to back up the fibre in order to get any coverage (stray as it is) at all.

After your edit regarding Windows/Mac: then the guess is that the Mac software will switch to a different connection type protocol with the cable fully plugged, possibly switching to a higher data rate that either the fibre quality or the monitors do not actually support or that causes some stupid copyright protection scheme to engage.

1
  • Thank you. I've updated the OP. As it turns out, the hardware is fine since it works on windows. This is a mac problem for some weird reason.
    – Bob
    Commented Jul 18, 2023 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.