0

When inserting VST instruments (Halion, MT Power Drums, etc), I can hear them just fine in my monitors and all looks well. But when I record they leave only empty waveforms, and when I stop recording, that whole waveform disappears. What am I missing?

I have the track enabled, just as I do for the instruments I record (audio track recording works fine). This is Cubase LE 12.

enter image description here

I've gotten them to work before, but it worked with default settings. Cubase will not allow me to open both projects simultaneously to compare settings (though they look the same). I can't figure out how to get the midi "notes" to record into the track in real time.

enter image description here

Edit: MT Power DrumKit provides the ability to drag an assembled set of drum parts into Cubase and create the midi track in the second screenshot, above.

8
  • "when I record" - how are you recording? These instruments aren't routed to an audio track; they're driven by midi & the audio is generated 'live' at each pass. To record the result, you either Freeze or bounce-in-place. [It's been so long since I used Cubase, you'll have too look in the manual for where these options are.]
    – Tetsujin
    Jun 18, 2023 at 16:13
  • I've done this before without the defaults and didn't have to bounce-in-place. That's a great suggestion, but not really the answer ;-)
    – Omortis
    Jun 18, 2023 at 16:39
  • This bit is worrying… "can't figure out how to get the midi "notes" to record into the track in real time" That's not really how you do it. You just bounce it. To do it your way, you'd have to route the o/p of your VSTi to an audio track input. Not something I've ever tried.
    – Tetsujin
    Jun 18, 2023 at 16:43
  • There has to be a waveform present to bounce it? without a waveform selected "bounce" is grayed out. The midi "notes" are not showing up (see the second screenshot, above).
    – Omortis
    Jun 18, 2023 at 16:50
  • No, you don't need a waveform - a VSTi doesn't produce a waveform, because it has no audio path except out to the mixer. Sorry, but without being able to see over your shoulder, I cannot figure out if it's something you've done, or something not behaving. I suspect you're hoping for a routing to an input, that simply doesn't exist.
    – Tetsujin
    Jun 18, 2023 at 16:53

1 Answer 1

0

I found the answer here, in the form of the virtual keyboard. I don't fully understand the answer yet but it does work and gives me a place to start w/r/t learning how MIDI works.

4
  • 1
    Sorry, but this answer suffers from similar to the question - it's just a link to a long discussion & doesn't really answer the question. We'd again have to be able to see over your shoulder to see what you were doing wrong & how you fixed it. I could hazard a guess that it was because you expected clicking on a keyboard on the VSTi to record its output…
    – Tetsujin
    Jun 19, 2023 at 14:10
  • I agree. I am tempted to delete it.
    – Omortis
    Jun 20, 2023 at 1:43
  • HOLD. UP. You were asking about recording audio, That post is talking about recording MIDI. That's right, right? Or have I missed something here?
    – n00dles
    Jun 23, 2023 at 22:53
  • You are correct. Even though I know the difference, I was conflating the two in my question.
    – Omortis
    Jun 25, 2023 at 1:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.