1

I have an ancient slightly mysterious full size keyboard that I bought from eBay a while ago.

enter image description here

I want to use it as a controller for my M1 MacBook Pro running MacOS 12.6 and GarageBand.

The keyboard has no manufacturer's mark on it, other than a logo saying "2way speaker system, general MIDI, and a number "70039" on it.

Rear panel has nothing either: rear panel

I'm connecting it to my MacBook Pro via an "Otracki" MIDI to USB interface.

The Otracki has LEDs on it, which flash when I play notes on the piano keyboard, so I'm fairly confident MIDI is getting to the Otracki adaptor. (I tried reversing the In/Out cables which resulted in no flashing lights when I played, so I think they're the right way around).

Then I plug the Otracki into a Dell USB-A to USB-C adaptor.

(I've also tried an Aukey USB-A to USB-C hub to check whether the adaptor is faulty - both work fine with other peripherals)

When I open the "Audio MIDI Setup" app in MacOS, I see a "USB MIDI interface" that is active whenever the Otracki is connected using either hub.

grab

What I cannot get is any notes to play in GarageBand, or any other music app.

no play gif

I've used other external keyboards with a direct USB-Midi connection into the MacBook and GarageBand before, so it's something to do with the keyboard/otracki config I think.

The Otracki amazon page says it doesn't need drivers. The device is detected by MacOS.

In GarageBand settings no MIDI controller is detected. Resetting MIDI drivers has no effect.

Advice?

4
  • Just to eliminate the obvious… have you tried the top end of the keyboard? It's an "ABC" accompaniment player, so the lower half [below some undetermined split-point] may not output, or may output something other than strict note data.
    – Tetsujin
    Commented Apr 10, 2023 at 8:39
  • 1
    Good idea - will try at home
    – tomh
    Commented Apr 10, 2023 at 11:04
  • 1
    Found what it is - 'Vidal XL'. Not much info on their site - vidaxl.com/e/… [slightly different number, but close enough;) - best I can come up with for a manual is 'contact customer support'.
    – Tetsujin
    Commented Apr 10, 2023 at 12:24
  • very helpful thank you! I will try some other cables directly into my Tascam US2x2 and see if I have any more luck
    – tomh
    Commented Apr 11, 2023 at 9:34

1 Answer 1

3

It was the OTraki adaptor, or the combination of that and the keyboard. Replacing with 5 pin MIDI cables into my audio interface fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.