Just today my Blue Yeti has started putting out what was described to me as on TS and Discord as "alien robot sounds". When monitoring it through its 3.5 mm jack, I don't hear it, but I have been hearing a high-pitched whine when there's no other sound coming through for some time now.

The sound occurs when listening to the device through the Windows sound settings, in VoiceMeeter and is transmitted in all VoIP apps I've tried. I have no other machine to test with.

Gain 35%, Windows volume 50% https://voca.ro/19BQ8eaLXC9p

Gain 100%, Windows volume 20% https://voca.ro/1oloLhUsUgqv

Tried: different USB cable, different USB port, unplugging neighbouring devices, restarting PC.

I'm not very audio-savvy, but I'll try to provide what I can if we can fix it.

  • Things that suddenly change often has a reason in a different change somewhere -- what have you changed ?
    – ghellquist
    Mar 18, 2021 at 21:40
  • Nothing, really. The supposed ground loop (high-pitched whine in the monitoring headphones) started after I had added two HOTAS USB devices in October (unplugging or different ports did not help), but the sound you can hear in the links above appeared suddenly on the day of the post. Mar 20, 2021 at 21:58


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.