0

I have a M-Track 2x2 C-Series USB audio interface, made by M-Audio, to let me convert an XLR signal into USB-C for recording on my computer. However, it seems to clip the audio easily and doesn't seem to give me the 'full signal.' What I mean by this is that when I record the audio in Audacity, it only seems to use half of the area represented visually. It seems to be capped at the ±0.5db mark. I've included a screenshot to better illustrate what I mean.

audio maxing out at 0.5db

I also have a Blue Yeti mic which doesn't seem to have this same limitation, so I know it's not simply a problem with Audacity. But I need the USB interface in this case so I can plug in an external mixer. Is there any way to 'unlock' that last bit of the volume spectrum? (Forgive me for not knowing the proper terms of art.) Or is this just a permanent limitation of the M-Track 2x2, and I would need to buy a different USB interface to get that full range to ±1 db? And would that help the problem I'm having with clipping?

UPDATE: When I connect the M-Track and the same input to my Linux computer, rather than my Windows computer, and record in Audacity there, I suddenly get the full spectrum as pictured below. So I think that narrows this to either being an Audacity problem, or a Windows driver problem.

linux

In any case I no longer think it's something inherent to my audio interface. But it could possibly be the driver. I'm still wondering if anyone else has been able to overcome this limitation?

2
  • As @ghellquist notes, the +/- 1.0 scale is not in dB. It is a linear scale, called "Waveform" in Audacity. To see a dB scale click on the black arrow to the right of "Audio Track" in your picture and choose "Waveform (dB)" from the drop-down menu that appears. I'd avoid using the term "full spectrum" to discuss the input range as the term spectrum usually applies to a frequency analysis of the signal. You can see this by selecting "Spectrogram" from the same drop-down menu. – Graham Nye Mar 11 at 23:40
  • As to why you are only getting 0.5 of the input range (-6 dB) try adjusting the Recording Volume slider (whilst your M-Track interface is attached and selected in the Recording Device drop-down) to see if you can use the full input range. (Called the Recording Slider in the online help.) Then you'll need to sort out your clipping as @ghellquist described. – Graham Nye Mar 11 at 23:52
1

Yes, the picture shows a heavily clipped signal. Decrease the input level until you never clip. Typical recommendation is to aim for around -10dB full scale when capturing input and to record at 24bit. This will get the best quality "raw" input you can get from the analog signals converted to digital realm.

Once you have a good quality input you may elect to process the signal. As it is a good digital signal, you can process it without decreasing the quality. The first typical step is to do normalizing. This modifies the digital signal so that the absolute max signal never goes above full scale. In effect a simple increase of volume.

What we tend to do in addition is further processing with the purpose to modify to get a "better" sound. Better definitely has one part that is subjektive, and taste and goals differ. Typical "first" steps might include:

  • high-pass filter to remove low-frequency "crud"
  • a gentle compressor to decrease the dynamic range slightly
  • a limiter to cut down a few very strong signals
  • and finally a normalizing to -0.2 dB or so.
4
  • But my question is really about why is the M-Track clipping at 0.5 db, and not at 1 db (like my Blue Yeti)? Why can't I record that signal in the 0.5 to 1 db range? – soapergem Feb 18 at 17:26
  • i have no idea really. But to very clear, it is not 1dB, the Audacity display is not in dB in this case (I believe there might be a setting you can use). And to be clear about dB, in digital fixed point (say 24bit) you can never have more that 0dB full scale. Regardless you are chasing the up the wrong tree if you want to maximize the signal when you should aim for keeping a good headroom. – ghellquist Feb 18 at 18:20
  • On second though, it might be your mixer that is clipping. It might be made to output consumer level, at "unbalanced" -10dBV while the line input on the sound unit is balanced +4dB. The mixer can not drive the line input all the way. What mixer? – ghellquist Feb 18 at 18:23
  • The mixer is an old Peavy PV-14 portable compact mixer, though I don't think that's at fault. Whether I have the mixer plugged into the M-Track, or just a single microphone directly, it's all the same, getting cut off in that first 0.5 range. – soapergem Feb 20 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.