For some months I've had problems with USB MIDI with the Babyface Pro and two of my DSI/Sequential synths: OB-6 Module and Prophet-6 Module.

I primarily use MacOS with Ableton Live, but I experience the same problem in Logic Pro X.

Whenever I play notes to either one of the synths, either with the Computer Keyboard (QWERTY buttons) or an External USB Keyboard (primarily Native Instruments Komplete Kontrol MK2 but I've tested with other External keyboards), some key presses will not play an audible note from the DSI synths, and some notes seem to get stuck hanging from the DSI synths. This appears to have no recognizable pattern; sometimes a note will play, sometimes it won't play and sometimes it will get stuck hanging. The intervals by which this happens seems arbitrary or according to some fractal pattern that I cannot discern, but usually it will not work randomly every, say, 1-6th key press.

My synths are connected via USB-A to my computer (Mac Mini 2018 running MacOS), which in turn also is connected to my Babyface Pro audio interface over USB-A. When I disconnect the USB-A cables to the synths and instead use MIDI DIN cables from the synths to the Babyface Pro MIDI Input/Output with a patch cable, the synths play normally and I get flawless audio!

Some notes:

  • I'm pretty sure the problem resides somewhere in USB-A MIDI Input and perhaps the interpretability to the synths, as there's nothing wrong with the audio output.
  • Again, I have the same problem in both Ableton Live and Logic Pro X.
  • I've had this over several months and versions of MacOS, including both High Sierra and Catalina. I have also tried to reinstall MacOS several times. I am currently running the latest version of MacOS Catalina.
  • I have uninstalled/reinstalled the Babyface Pro drivers multiple times.
  • I have tried clearing the configuration of the "MIDI Studio" in "Audio MIDI Setup.app" and create a new configuration.
  • I am able to connect a synth of another brand, the Elektron Digitone, using USB-A to the Babyface Pro and it plays perfectly.
  • It is probably unlikely that both DSI synths have had their USB components damaged in the exact same way, same goes for the USB-A cables. I have switched USB-A cables to other ones and still have problems, so I don't think the cables are faulty.

I'm really confused as to what could be the issue. To reiterate, the Babyface Pro works with an Elektron Digitone over USB-A MIDI, and the DSI synths work with the Babyface Pro over DIN MIDI, but the DSI synths don't work with the Babyface Pro over USB-A MIDI.

Could the MIDI drivers for DSI Synths on MacOS specifically be damaged in some way? Does there in MacOS indeed exist separate MIDI drivers for different synth brands, or is it only one single driver for everything?

Please reach out to me if you have any ideas or questions on how this can be resolved, as this problem has been ongoing for several months without any resolution. I really need help with this!

I should mention that I had this problem perhaps 6-7 months ago, and what I recall doing then was deleting some MacOS MIDI drivers from my Mac and reinstalled MacOS again. This was done on a whim, and after reinstallation everything worked again. I can't remember which drivers it was I deleted. Just reinstalling the OS again over the existing files doesn't seem to help though.

FYI OB-6 OS: 1.5.5
Prophet-6 OS: 1.5.9

Here is a sample output from the application "MIDI Monitor.app" which is downloadable for MacOS:

Time            Source                                  Message Chan     Data
14:31:37.638    From KOMPLETE KONTROL S61 MK2 Port 1    Note On 1   G2  65
14:31:37.742    From KOMPLETE KONTROL S61 MK2 Port 1    Note Off    1   G2  84
14:31:39.364    From KOMPLETE KONTROL S61 MK2 Port 1    Note On 1   G2  64
14:31:39.466    From KOMPLETE KONTROL S61 MK2 Port 1    Note Off    1   G2  65
14:31:41.064    From KOMPLETE KONTROL S61 MK2 Port 1    Note On 1   G2  62
14:31:41.186    From KOMPLETE KONTROL S61 MK2 Port 1    Note Off    1   G2  44
14:31:42.890    From KOMPLETE KONTROL S61 MK2 Port 1    Note On 1   G2  64
14:31:43.014    From KOMPLETE KONTROL S61 MK2 Port 1    Note Off    1   G2  47
14:31:44.513    From KOMPLETE KONTROL S61 MK2 Port 1    Note On 1   G2  64
14:31:44.642    From KOMPLETE KONTROL S61 MK2 Port 1    Note Off    1   G2  59

In this particular case, I only got audio from the synth on the 5th keypress (the last "Note On"), but none from the other key presses.

Note that the columns for "Chan" and "Data" are mixed above; couldn't fix in formatting.

Thank you very much!

1 Answer 1


I believe I found the culprit!

I have the application "Duet Display" for MacOS that makes my iPad act as an external display. I just had to quit the application and MIDI started working again.

I don't know if this has to do with a negative interaction with the DSI synths, the Babyface Pro or MacOS MIDI in general. But everything seems to work fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.