1

I've tried everything I can find on the internet. So hoping someone has other ideas.

I have a Numark Party Mix and cant get it to connect to my Mac.

Its not showing in Midi Studio in the configuration, I've unplugged and plugged back in, made a new config and refreshed and nothing. IAC Driver is also grey, does this matter? Its not recognised by Virtual DJ, Traktor or Serato after plugging in. It's definitely connecting as all the lights come on. I've registered the product, created an account, logged in, activated my serial number. Uninstalled, reinstalled. All that happens is all the lights flash including all the buttons. Like its in standby. What can I do?? Running Mojave 10.14.5 OS.

Thank you

  • I'd ask Numark - their site doesn't claim support for Mojave, only up to High Sierra. there's probably something you need to allow through Gatekeeper. – Tetsujin Oct 5 at 10:08
  • Found this - numark.com/kb/article/2431 – Tetsujin Oct 5 at 10:09
  • It looks like it makes the list of Class-Compliant Supported Hardware with Mojave 10.14. No additional driver needed. So I don't think that's the problem. Thanks for the link! – Joe Oct 5 at 10:55
0

In the end I got it working by using a different USB adaptor. It seemed that the connection from the Numark to my Mac needed to go via an older connector then into the usb c adaptor. And now it works perfectly! I don't know why this matters but the older usb 2 adaptor got it going.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.