-1

I've used Blender Video Editor to create a movie made up of still images accompanied with sound. The movie has to be played in RPG Maker XV Ace and has to be an OGG/THEORA file (.ogv).

The movie is perfectly fine when played with Windows Media Player but with RPG Maker, the sound is distorted and "jumps" (like when we were playing records in the '90s..) when there are high pitched or reverberating instruments.

The following are my settings for the movie output:

Container: OGG

Video Codec: Theora

Audio Codec: Vorbis

Bit rate: 160 (16 bit)

Sample rate: 44100 (44.1 kHz)

System: Windows 10

Video Editor: Blender 2.79

I have already tried increasing (170, 200, 220, 320) and decreasing the bit rate and the frame rate (48000) but to no avail.

I've got a much better result when rendering the movie with the lowest quality and by setting the ENCODING SPEED to the lowest quality but still the output is not perfect.

I've made a sample where you can check the quality of the ogv.file (the image is just a drawing) and the result in the game engine (recorded with OBS):

This is a sample ogv movie

This is what the music sounds like in RPG Maker XV Ace

The problem seems to be more evident with high pitched or reverberating instruments. The sound contained in the sample was made with LMMS and adjusted (only in terms of fading in and out) with Audacity.

I have installed the latest version of K-Lite to get the latest video and audio codecs.

Thanks for your help!

-1

I didn't follow what RPG Maker suggests in the help menu and played around with other video codecs. This is the optimum quality:

CONTAINER: OGG

VIDEO CODEC: H.264

OUTPUT QUALITY: CONSTANT BIT RATE (This is very important)

ENCODING SPEED: Medium

AUDIO CODEC: VORBIS

BIT RATE: 200

FRAME RATE: 48000

Now it works like a charm!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.