-1

Usually when I play a multichannel MIDI file from my sequencer to the sound module (for example, Logic Pro), I get multichannel playback. By that I mean, different instruments playing their independent parts simultaneously.

I have a Yamaha PSR 340 with a MIDI in (as well as 'out') port. But when I play out to this, everything comes through one instrument on the keyboard only. All channels get played as piano and obviously sounds terrible.

Why is my keyboard different to other MIDI sound banks in this way? Could it be something to do with MIDI type 0 being on the keyboard rather than MIDI type 1? Is there something I can do to fix it? I need the instruments/channels to be differentiated so that the music sounds correct.

  • This could be because of cheap software (you have not mentioned which you are using) but it's more likely to be poor config. We would need more detail in order to provide an answer. – Rory Alsop Jan 13 '18 at 0:53
  • Thanks for reading. I've re-written it. Hopefully it's clearer now. – TenLeftFingers Jan 14 '18 at 9:40
0

According to the manual, function parameter 81 "Remote Channel" selects which channel to use as keyboard input. This channel will not be multitimbral but controlled by the keyboard's own settings. You want to switch this one "off" when using your keyboard as sound expander.

  • I've just tried Remote Channel set to "off", but everything still plays on whatever the selected instrument is. – TenLeftFingers Jan 16 '18 at 21:44
0

Possibly your keyboard is set to receive 'all channels' on that instrument. You may need to manually assign channels to individual instruments.

This would simply amount to a difference in implementation from that manufacturer (to allow "greater flexibility" etc.).

0

The issue has been solved. The typical USB to MIDI cable that is available online at bargain price is prone to all kinds of issues I've discovered on other threads on the internet.

Buying a more expensive Roland UM-ONE mk2 USB MIDI Interface was recommended to me and as soon as I swapped the old cable with this all issues went away.

After testing some more, the duplicate and stray notes and control signals are actually present in all applications - even the ones you don't hear it in. Modern technology like Pro Logic can mitigate these issues, but using a software MIDI debugger shows that they exist there too.

So it wasn't the case (that I originally thought) that the problem only existed in one context, it was in them all. The cable solved the problem.

Thanks to all for your answers. In the end, this is what fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.