-2

Background: We have 2 furman power conditioners/sequencers (ps-8r) that, from what I am told, talk to each other. Recently, the remote ps-8r stopped working properly. It seems to be stuck at "Delay 1" flashing. I assume that means there is power to the ps-8r. However, when I press the momentary switch (round white push-button switch on front panel) there is absolutely no effect on the unit. I tried disconnecting everything from the unit, then remove the power from the unit, waiting several minutes to make all "memory" reset, and then plugged it back in and tried the momentary switch again, with no effect again. I was expecting to have the power removal cause the unit to go back to default operations.

The main question is, how do I force the unit back to its default (factory) operations) so that the white momentary switch on the front panel will cause the unit to sequence up?

  • 2
    I posted here because this question specifically relates to power conditioning for sound equipment, which I would expect other sound engineers make use of as well. I didn't see a "sound hardware" stack exchange site. My guess was that a sound engineer somewhere may have encountered this problem. Added "hardware" as a tag to provide clarity. – Joel Nov 27 '17 at 12:53
  • 2
    I'd concur that this is on topic here. It has to do with the use of professional equipment being used for sound reinforcement or production. The fact that the particular piece of equipment doesn't directly touch the audio pathway doesn't really seem relevant since it's still indirectly related due to providing consistent power to all components, which is important to proper function of the audio pathway. – AJ Henderson Nov 28 '17 at 15:48
  • 1
    I'm voting to close this question as off-topic because this is a factory support question. – Mark Apr 24 at 2:24
  • Does closing it as off-topic imply that questions relating to factory support do not belong here? As I mentioned in my above comment from over a year ago, I was simply hoping that someone else may have encountered this problem before. Indeed some good input was given. I never marked an answer because we never found a resolution. We ended up replacing the equipment. – Joel Apr 24 at 12:26
0

I would check the wiring between the two units, and the state of the remote unit.

The manual details the following on page-5:

Blinking DELAY 1 Indicator

In Maintained Mode, the DELAY 1 LED on the PS-8R blinks whenever the unit is OFF (the remote switch is in the OFF position).

In Momentary Mode, the LED blinks if the “memorized” state is OFF.

Also stated on the same page:

Be sure that the mode (momentary or maintained) of all units is set the same.

Momentary mode and Maintained mode are explained on page 4.

If you do have more problems, you may try calling their technical support

[EDIT based on comments]

This particular power sequencer needs a remote switch for power on or off. The wiring is described in the manual on previously mentioned page 3/4, and is dependent on the jumper setting on the main board. To change the jumper setting on the main board one need to open up the unit.

I would strongly advice you not to open the unit if you are not certain. It is impossible to asses your expertise in this, hence this warning. If you are not experienced in this, please contact an experienced installer and|or call Furman support.

The fact that you have disconnected the cables is probably going to further complex the situation if you do not recall the original wiring (which wire connected to what terminal), unless you have taken note when disconnecting. And some of the wires very likely go to the remote switch which you need to turn this unit on.

It is a mains unit, so whatever you do, disconnect before doing anything !

[EDIT based on logical thoughts]

As you have disconnected all cables, there is no connection at the terminals at the rear of the unit. Given the fact that the unit is blinking, without any wires, It could mean that the jumper is installed on JMP2 which is "Momentary Mode".

It is likely that this particular situation is "Memorized OFF" in "Momentary Mode", which means if you connect REM terminal, just momentarily, with +12V terminal, the unit should come on.

However I cannot be sure of this !!! ... at your own risk ...

  • I read this same section of the manual, however it directly relates to the unit being connected to a remote. Granted, originally the unit was connected to a remote unit, but as I mentioned in the background of the question, I disconnected all cables including power, let it sit for several minutes in order to "reset" it to normal (non remote) mode, then only plugged power back in to the wall. The unit would still not sequence up in normal (non-remote) mode. – Joel Nov 29 '17 at 13:52
  • Eventually I would like to get it back to remote mode, but initially I am focused on getting it to operate properly by itself. Maybe a good initial question is how do you switch between "maintained mode" versus "momentary mode"? – Joel Nov 29 '17 at 13:52
  • Calling their tech support is an option, but I am hoping that someone has encountered a similar situation, so as to avoid sitting on tech support hold. – Joel Nov 29 '17 at 13:53
  • @Joel answer updated – Edwin van Mierlo Nov 29 '17 at 14:05
  • @Joel answer updated again – Edwin van Mierlo Nov 29 '17 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.