I've gotten myself a Steinberg UR22mk2 USB audio interface. After plugging it into my Linux system (Kubuntu 17.04 with kernel 4.10.0) it is automatically and correctly detected.

The problem I have is: whenever an certain applications (re) opens an audio output channel and plays back audio via the UR22mk2 with the earphones connected to it, there's an unwanted and slow audio fade in. It happens in Kdenlive, but neither VLC nor Audacity.

This is very annoying when editing video+audio in Kdenlive, because whenever stopping playback and restarting it in order to find the correct cut positions, the automatic audio fade in kicks in and makes editing unusable with the Steinberg. My Behringer QX1202USB doesn't exhibit this behavior. However, both seem to use the same stock USB audio Linux kernel module.

This only happens with the Steinberg UR22mk2 USB audio interface, but not with other USB audio interfaces, such as my Behringer UX1202USB audio interface. This is not a hardware feature, but software: when I connect the UR22mk2 to an Android tablet, there's no audio fade-in, but the audio playback is immediately present as it should.

Is there a hidden (and probably not well-documented) driver setting for the UR22mk2 to disable this audio fade in? Or is there some Linux audio system setting(s)? I've looked around and searched and searched ... but to no avail so far.

Any suggestions?

  • 1
    I suspect you might be luckier in Ask Ubuntu for this kind of question as I suspect (I might be wrong here) that it's an Ubuntu issue and not an audio interface one. Commented Aug 8, 2017 at 19:00
  • 1
    I looked into your problem largely out of curiosity and found this article. Are you by any chance using 'ear candy'? It appears that this is its main function (to fade things). Commented Aug 8, 2017 at 19:24
  • 1
    @Schizomorph, no, I'm not using earcandy. This is one of the few things I also found.
    – TheDiveO
    Commented Aug 8, 2017 at 19:25
  • Have you tried using a different driver? 99% of latency problems I have come across are caused by an incorrect driver being used. I have no experience with linux but this MAY be the issue. Have you ever heard of ASIO4ALL?
    – Daniel
    Commented Sep 5, 2017 at 13:03
  • David, thanks for trying to help. ASIO4ALL is Windows only and trying to work around the broken performance on this platform. Your advice of rying another driver is as generic as it is useless on Linux, more so as the Linux kernel already is a) low latency, and b) comes with the USB driver for the UR22mkII. And if your reread my question, you should notice that this is not a latency problem, your whole comment doesn't answer or help in any way with my issue, and OS platform. Thank you for trying, though.
    – TheDiveO
    Commented Sep 5, 2017 at 17:56

1 Answer 1


Some more digging shows that the unwanted 2 secs audio fade-in happens only with some applications, most notably the Kdenlive video editor (and also MLT/melt), but not others, such as VLC media player and (phew!) the indispensable Audacity audio editor.

Luckily, I've now found a setting that allows me to work with the Steinberg UR22mkII in Kdenlive without any annoying fade-in, see below (spoiler: use ALSA as the audio driver setting).

But first for details: audio in VLC just works fine, with its audio output module set to

  • automatic
  • pulseaudio
  • ALSA

Audacity only has "ALSA" and "OSS" anyway, but no PulseAudio. So the plot thickens.

In contrast, Kdenlive behaves either good or bad, depending on its audio driver settings (but the audio backend doesn't matter, regardless whether it's "SDL" or "RtAudio"):

  • automatic: fails with annoying 2s audio fade-in.
  • PulseAudio: fails also with 2s audio fade-in.
  • ALSA: finally works as expected without any unwanted 2s audio fade-in.

Maybe someone can shed some light in the comments on why PulseAudio behaves differently when used by some applications compared to other applications; could be different API calls, per chance?

  • I have had a different interface do this when the sample rate or bit depth are changed. It could be that the different programs are using different sample rates, causing the interface to switch modes which will cause a pause in playback. The fade in effect is probably to avoid popping and crackling.
    – burneddi
    Commented Jul 5, 2020 at 0:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.