2

My H4N works perfectly by itself, but when I connect is as USB mike to my macbook bro, all the audio from my voice sounds high pitched.

Any advice what to do?

  • 3
    I don't know the H4N, but best guess would be one is set to 44.1, the other to 48kHz. Look at Audio MIDI setup in Applications/Utilities – Tetsujin Mar 1 '17 at 18:52
  • @Tetsujin thx, how would this help? – SuperUberDuper Mar 2 '17 at 21:20
  • do they have to be equal? – SuperUberDuper Mar 2 '17 at 21:21
  • great, that worked, please add to answer) – SuperUberDuper Mar 2 '17 at 21:24
2

I had this exact issue for ages on MacOS, audio was high-pitched & had intermittent silence. The fix was to make sure that the Audio Rate setting on the H4N was set the same as the driver's setting in "Audio Midi Setup".

The problem was that the driver was trying to read 48,000 samples a second from the device, but it was only recording at 44,100 samples a second. Every other sound device I know of just trusts the driver to set the rate correctly so I didn't even check :eyeroll:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.