0

When you import a MIDI file into a Cubase project, you're asked to either create a new project to import into, or import into the currently active project. You cannot select multiple files in the first import.

The tempo will be used from the MIDI file if it is the first one (and the projects tempo track is empty). In sub sequent imports of other MIDI files, the tempo is ignored.

Moreover the imported file is always placed in the beginning of the project, regardless of locator and marker placements.

If you instead try to import tempo track from another project, the outcome is similar, only the existing tempo track in the project is discarded/overwritten.

The client may deliver midi files from notation software like Guitar Pro or their own demo/rehearsal projects. If you want to record and mix multiple songs in one project this is a huge problem.

So how do you import multiple tempo tracks or MIDI files in one project?

(manual tempo track setup is not a solution)

2

There are some well hidden impractical default MIDI import options in Cubase's preferences that prevent this. Here is how to fix it:

  1. Go into Cubase's preferences window and go to MIDI -> MIDI File
  2. Find the option that says Import to Left Locator make sure it is checked
  3. Find the option that says Ignore Master Track Events on Merge is unchecked.
  4. Now you can set the left locator to where you want the MIDI/tempo to be imported to and go to File > Import > MIDI File and choose the one you want.
  5. Then set the left locator where you want the next one, import MIDI, and so on...

You can delete the MIDI tracks/events afterwards if you want, the tempo will remain.

When it asks you if you want to create a new project for the MIDI file, click on No

(source: http://www.ultimatemetal.com/forum/threads/inserting-multiple-tempo-maps-in-cubase-5.734268/)

  • 1
    Yeah - I used to do this a lot, but it's been so long that actually I'd completely forgotten. +1 for reminding me. – Tetsujin Feb 29 '16 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.