1

I have a computer with a keyboard synthesizer. I created 2 MIDI tracks. On each of them I added a virtual instrument, and I assigned a channel number to each of them (track one, channel 1 of my device, track two, channel 2 ...).

My problem is: when I select (I click on) Track 1 and I played on the synth, all is ok. when I select track 2 and I played on the synth, I hear the track 1 (and not the 2).

In other words, I have to manually change the channel from the synthesizer (set it to 2) to hear the track 2.

The twelve o'clock output Seems To be configured Correctly ...

In fact, I could simplify my question, I realized that the 'problem' is the same with the virtual keyboard: whatever the chosen track the midi channel must be changed manually.

1

Your device will not change output channel just because you select another track in Reaper.

Some alternative options to consider:

  1. Set up the Reaper tracks to track 1/channel 1 and track 2/channel 2. Then only change channel on your device (depending on model you may be able to store that with a preset).
  2. Set up the device or reaper to omni/all inputs or set the Reaper tracks to the same channels and then use mute/solo buttons.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.