3

I've got an Alesis iO2 Express and a Samson c01 mic plugged into my Mac. The Alesis provides two channels of input, one for each of the mic inputs available on the device. If you plug the mic into the left input, you get sound through the left channel only, and similarly right channel audio for the right input.

Is it possible to force the input device to only provide one channel of audio, regardless of which input socket I use? I'm recording with one mic, so I don't want the sound to only come out of one channel.

I've tried looking in the 'Audio MIDI setup' utility, but it reports that the device is using two channels and there is no option available to change it to one.

If I use Audacity to record audio, I can force the recording to one channel. This would work fine, but I actually need to record via QuickTime, so I'm still stuck with one channel of audio (unless I always record audio separately in Audacity). Are there any other settings or apps which can force the device to one channel of audio?

Any help with this appreciated

  • It is the QuickTime problem. It looks like it can only record in stereo. What's wrong with using Audacity/Garage Band/Logic? – Chris Koston Apr 9 '15 at 21:09
  • I'm making a screen recording, so without having to purchase something like Camtasia, QuickTime is the only good quality free way I can find to do this. The only workaround I've had so far is to record in QuickTime and Audacity, then join and sync the two in iMovie. It would be great if I didn't have to do this though. – Dan Murfitt Apr 13 '15 at 18:27
  • Have you tried using Soundflower from Rouge Amoeba? rogueamoeba.com/freebies/soundflower – Winston Chow Apr 23 '15 at 17:54
1

Purchase a splitter adapter that takes your mic output and splits it into left and right channel. If your mic is mono, it will just send the same signal down both.

Like Winston Chow mentioned, you could use soundflower to re-route your audio but if that's too much hassle, the hardware solution may be a much better, simpler solution.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.