I have a Blue Yeti USB microphone which when recording produces a "frying mosquito"-type noise (sound clip here: https://clyp.it/cw0jhzfa).

I've tried it on three different computers (both laptop and PC), on Windows and Linux, using different recording software, different cables, moving the microphone away from the computer, making sure nothing else is interfering, etc, etc, but it makes no difference, with one exception: when I use a very, very short USB cable (like a couple of inches) it doesn't occur, but anything longer than that and it does.

This is actually my second replacement of this microphone. The first one was cosmetically damaged but didn't have this problem. The second one did, which is why I sent it back again to the supplier. Unfortunately this one has the same problem.

Reading a few forums, it seems other people have come across the same thing with this mic, but I've not read any solution to it.

Does anyone how/if I can fix this? Thanks.

  • This sounds like a hardware fault - get replacement from the supplier.
    – Rory Alsop
    Commented Mar 3, 2015 at 8:39
  • This is already my second replacement! And the last one had the same problem.
    – Paul
    Commented Mar 3, 2015 at 12:02
  • Poor batch? Poor quality control. Still a faulty product - get it replaced again (ideally with something better)
    – Rory Alsop
    Commented Mar 3, 2015 at 14:10
  • I've had the exact same problem. Sadly I have no clue what to do. I had a blue yeti in the past and it completely broke. So I got it replaced and the replacement is making the same buzzing noise as you have. No idea why. It's getting me very annoyed because when I have my first yeti replaced, it took over 4 months, so I'm not going through that again just for another defective microphone.
    – user13138
    Commented Mar 12, 2015 at 2:44

3 Answers 3


I have an Alesis iO2 that makes a noise like that when the gain is turned up. My best guess is that there is some DC-DC converter noise getting picked up by the amplifier inside the mic. You need to isolate the mic's analog section from your computer electrically to fix it.


I would suggest to eliminate a ground loop that is propably happening somewhere in your chain. You can try to use a usb ground loop isolator like this : https://electronics-shop.dk/?id=1038&username=&currency=USD

The solution to use a ground lift plug on your PC AC plug has been identified as a serious safety problem, so I wouldn't recommend it but it would have the same effect.



I just bought a Blue Yeti and had the same problem. My mbp 2017 has only usb-c ports, so I had to use an adapter. I tried 2 different ones and 3 different cables. One worked and got rid of the buzz, but it is only about 12 inches long, not very helpful. I figured that it was probably a cable issue so I went on amazon and ordered a Mini usb to usb-c cable, 3.3 ft, still kind of short, but it works! No more frying mosies. I hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.