2

I have a brand new clean Windows 7 64bit SP1 setup with newest hardware (i7-4770, SSD 1TB, 16GB RAM etc.). The main utilization of the computer is music production.

However, I have problems with random micro audio drop-outs. They appear randomly no matter of how much is the processor utilized. I notice a sound lag once in few minutes, or sometimes it is only once per about 15 minute period. I belive lags are no longer than about 200-300ms. They are definitely much shorter than a single second.

My USB sound interface is Steinberg UR-22.

I already tried to reinstall USB drivers, change buffer sample rete, however nothing helps.

In one of my massive FLStudio projects the processor is not utilized more than 20% of the computing capacity. RAM usage is usually not more than 5 GB (so still 11 GB are free). Therefore I don't think the dropouts are hardware problem. I also don't think it could be a buffer problem, because FLStudio does not show any audio drop out information (it would if there was a audio buffer underrun detected).

Also the Steinberg audio interface is completely new and works like a charm with my MacBook (late 2013).

If you have any clue what could couse the problem I would appreciate any advice. Thank you!

  • Please don't cross-post to different SE sites. What driver are you using? ASIO or windows? – Tetsujin Jan 11 '15 at 9:54
  • Its native Yamaha driver. For DAW application it is Yamaha ASIO driver, for Windows applications it is Yamaha driver for Windows. I have the latest official drivers from Steinberg web. – tomexx Jan 11 '15 at 10:46
  • have you had a look at DPC Latency Checker see if it gives any clues? – Tetsujin Jan 11 '15 at 10:55
  • 1
    I tried DPC Latency Checker but it did not noticed any of the lags. However I turned off integrated audio interface on MSI mainboard and I also switched off some of the mainboard features and now I am testing the sound behaviour. So far no audible problems. I will continue inspecting the issue. – tomexx Jan 11 '15 at 13:20
0

I found a solution in my case, I was having the same issues. Would drop on my 2 windows desktops but worked fine on a windows laptop. My solution was to change out the USB cable that came with my device. My device is a Steinberg UR-12 but this seems to be a re-occurring problem in all the UR series.

Doing some research I discovered that USB cables can have different power gauges in them. When I first tried 2 different USB cables the sound drops were worse...much worse! (more frequently and longer) The 3rd cable I tried did the trick. If you buy a new one you should try to get a cable with 28/24 gauge wiring. (I believe that is the strongest gauge you can get) The one that worked for me was from a USB hub that came with my desk. I suspect the difference in it is that it has the better gauge rating.

Hope this helps in your situation! Cheers

2

These things are usually due to a process with higher priority kicking the sound recording process off the CPU for long enough to drop a buffer. On Windows, I have heard this usually being the result of the wireless driver, which for some insane reason has a very high priority. You basically need to ensure your soundcard is running at the highest possible priority in terms of importance. Lots of things can interrupt recording, so it's good to know what services are running and whether they will get in the way when you record.

Check out this on priorities and start there. I do sound with a guy who has a windows laptop and has had to turn off wireless and all sorts to guarantee no dropouts, as well as boosting the priorities appropriately.

If you want to debug this accurately, then you need to keep an eye on what the system is doing when you get a dropout. I would probably do this by getting the system to start recording automatically (so you know it's right) at a given time and then seeing in the recording when the dropouts occur, so you have a very accurate measure of when things are going out. You then need to know the size of your buffer to get it spot on, but it sounds like you don't have the 30 second buffers of web clients so you should be able to have a look in the event log and the system log as to what's going on around that time. And then deprioritise that process or disable it during recording (I'd probably do the latter if I were you unless it's essential for what you're doing).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.