2

I'm working with protools 10 hd .my sound interface is audio komplete 6 and my recorder is zoom h4n.whenever I record something(even without plug ins) I've got delay. I wonder if there is a way to not have this delay.

  • 4
    don't monitor through, monitor direct; otherwise you have latency. Dropping the buffer size will reduce latency, at the cost of processing power. – Tetsujin Dec 14 '14 at 17:37
3

Some delay – proper word: latency – is inevitable whenever you monitor something through software: this always requires some digital data to be passed into the software, be processed, and passed out again – on general-purpose hardware that can only be done efficiently when you pass whole chunks of samples, usually something between 64 and 4096. So e.g. at 48 kHz, you'll have a latency of at least a few milliseconds, up to ~100 ms which is very notable.

Any professional sound drivers (Core / ASIO / Jack...) will let you choose a selection of buffer size and thus influence latency; at least when not using effects you should get it down to around 5 ms, which is typically ok (similar to the delay you get from speakers placed a few metres away). Check out the Komplete 6 's settings.

Now, what's strange is that you say your "recorder" is the h4n. That, being a field recorder, is of course not primarily intended to be used online. I'd have to guess how you actually connect it:

  • The h4n should be able to run on USB as basically a small audio interface with built-in mics, with its own drivers & settings. Then you don't need the Komplete 6 at all. Should work fine, though the h4n is probably not that good in that role (including, it can't do as low latencies as the Komplete 6).

  • You can use the h4n as simply a stereo mic – use analog line-out or whatever else into the Komplete, which is then the sole audio interface. Again, should work fine, though this isn't really an intended use of a field recorder, either – you might be better off with a pair of ordinary condenser mics.

  • It is possible to use multiple different audio devices on the same computer. But it's usually not a good idea, in particular WRT latency. The reason being, the software can't just fully rely on a single, device-specialised driver anymore, but has to juggle multiple drivers, which need to be more forgiving and handle clock synchronisation or resampling, mixing etc.. This is therefore the realm of consumer drivers like Windows Sound System or PulseAudio, which are not well-suited for any professional work. If you have both the Komplete 6 and the h4n connected by USB, you may be able to record "from one to the other", but you probably won't be able to achieve low latency. Also, it's not really reliable. So, choose between Komplete 6 or h4n. Probably best: Komplete 6 with ordinary condenser mics.

When using only one audio interface, and don't need the monitor to be processed, then you can (as Tesujin suggests) in fact get the latency to zero by using direct monitoring, which doesn't pass through software at all but goes right from the mic inputs to the headphones. Check this out. It saves you from having to set the buffer size very low (which tends to make the audio a bit unstable, even when the drivers are good).

2

You should drop the buffer size from your sound card settings until the point your CPU can handle. Aim for less than 10ms of latency. For example a guitar player standing 3m away from the amplifier experiences a 10ms delay. 3ms should be quite unnoticable.

If you are not applying any insert effects you can use direct monitoring for 0 latency. But even with a few effects in the chain you should be comfortable with recent computers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.