-1

I have two instrument tracks, both assigned to MIDI 1. However, I have a Key limit on one from D-2 to F4 and on the other from F4 to G8. I then have two separate instruments assigned to each track. If I select track 1 as seen in the diagram, only instrument 1 will play, and it will only play its notes within the range specified. When I select track 2 and play on my keyboard, only instrument 2 will sound. How do I fix this?

enter image description here

When I hit play, the two tracks will play as expected, with each instrument playing its respective parts.

I'm using Logic Express 7.

  • 1
    This is a technical question about midi, not a sound design question. Have you tried asking this on the Apple/Logic forum? – Arnoud Traa Mar 14 '14 at 14:00
  • I use Logic Pro 9 and seem to have different options. I would be using the record enable feature, but it doesn't seem that you have that for MIDI instruments in Express... You may find that this isn't possible or significantly difficult with Express. – Basstickler Mar 14 '14 at 14:05
  • Technical specific question that really should go to a logic forum. – ErikG Mar 14 '14 at 16:54
  • This is a specific technical question regarding audio production. As this would have been on topic at AVP, it is on topic here until/unless a redefined scope discourages it. – JoshP Mar 17 '14 at 20:49
0

go to environment, create yourself a midi object - a transformer or anything else, that you can then connect to both channel strips in question. tick the box next to the icon for that object which would allow you to create an arrangement track for it. see the manual for more details.

indeed this is not a sound design question..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.