1

I luckily found the answer to this problem, so I'm going to self-answer this.

Problem: MIDI input lags by 3 - 5 seconds (not a buffer size issue).

Setup:

For me:

  • Yamaha YDP-S30 digital piano
  • E-MU Xmidi 1x1 Tab
  • Some software capable of receiving MIDI (e.g. any DAW; Cubase for me)

Remarks:

  • This setup had previously worked with no issues (3 - 4 days for me) until it suddenly failed
    • Which means none of the following were relevant (I had these settings for days):
      • Using ASIO drivers to decrease latency
      • Changing the ASIO configuration (specifically the buffer size)
      • Unplugging devices from USB ports to decrease latency
      • Reinstalling drivers, configuring the software, restarting the computer
2

Solution: Send a MIDI SysEx "reset all" message.

What worked for me:

  1. Download MIDI-OX for Windows or KMidimon for Linux. I use Windows so these steps will continue with MIDI-OX.
  2. Start MIDI-OX. Go to Options->MIDI Devices. Select your MIDI input ("E-MU Xmidi1X1 Tab" for me). I actually selected Microsoft GS Wavetable Synth for my MIDI output, but I don't think it matters what you select. The input is what we're interested in.
  3. Go to View->SysEx... to bring up the SysEx View and Scratchpad window. We will be sending a MIDI reset command through this window.
  4. Somehow find a table describing the MIDI commands you can send. For me, I found this table in the YDP-S30 manual, which I quickly found on Google. The MIDI commands we are sending are device-specific (the manufacturer chooses which code means what), so you probably can't get past this step without the proper MIDI code table. Here is an image example of the relevant portion of the MIDI table I used.
  5. Play with the codes to send the appropriate message. Here is an image example of MIDI-OX sending the code. I think that reset my MIDI device, because everything is working now with no input lag. Use Command Window->Send/Receive SysEx or just Send SysEx (I spammed both to make sure).

I still have no idea what caused the problem. My guess is some software sent a particular MIDI message which caused all messages to arrive late?

  • This happened to me again, and this time sending the SysEx message didn't work. The delay seems to be actually caused by dust between the USB cable end and the port. I used a gas duster on both the cable tip and USB port and the delay was gone. – Jason May 3 '14 at 4:02
  • This happened again and the gas duster was the only thing that worked. So strange that theres a half a second delay, and restarting everything and plugging things in in different orders don't work. But a quick squirt of compressed air to the usb end of the USB MIDI interface and some to the USB port on the computer itself, and theres instantly no lag. – Jason Sep 5 '15 at 20:59
  • A great audio guide from Cantabile explaining in-depth how to tune Windows for real-time audio: cantabilesoftware.com/glitchfree – Jason May 14 '17 at 9:48
1

This exact thing is happening to me. I tried updating the drivers, but that didn't help.

The only consistent feature that seems to take the lag away is to unplug the USB device, wait at least 10 seconds, then plug it back in. Once plugged in again, it works like a charm. Having the device plugged in during boot-up slows it down for some reason. I'm guessing that the software reset accomplishes the same thing. I really would like to find an alternate fix to this because my computer is running from another room. Has anyone else found more permanent solutions? Thanks.

1

Had the same problem with E-Mu MIDI 1x1, windows 7 64 bit. Disconnectng and reconnecting the MIDI USB solved the mystery delay.

Thanks.

1

I have experienced the same issue, including just yesterday preparing for a live performance, and thought the unit was broken. Apparently based on your post, it is a bug in the 1x1 itself.

To resolve the problem, unplugging the 1x1 and re-inserting it usually rectifies the issue. Very annoying... This effectively resets the unit.

  • So strange! I never expected more people than myself to have this problem, but what do you know .... Looks like squirting compressed air into my USB slot has nothing to do with it (I didn't seriously think it could), and it's just unplugging and plugging it back in that fixes it. – Jason Jan 24 '17 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.