I have recently bought a low-end usb keyboard(Acorn Instruments Masterkey 49). I am trying to use it with Sibelius 6. After spending a lot of time in the settings of Sibelius, I have managed to get latency down to 10ms, although I am not happy with that. I am using a laptop so I'm thinking this must be the limit for my current hardware.(CPU/GPU are good but I'm guessing sound is rather basic) I was told that this latency is probably due to my sound card.

After a lot of googling I couldnt find any external soundcards that seem to work for me. Can anyone suggest some that I should look at? Keep in mind the keyboard I am using only has USB connection. Thanks !

p.s I am a uni student, and using the above equipment for my studies, so professional equipment is out of budget.

System Info

Win 7 64bit i7 3610QM 2.3Ghz 6GB RAM Realtek High Definition Audio(WASAPI)

Sibelius supports ASIO drivers although the system doesn't(option is visible in settings, but greyed-out).

  • 2
    The delay you're noticing is primarily from your sound card, not from your keyboard.
    – Brad
    Jan 1, 2013 at 20:06
  • Yes I am aware of that.
    – Giannis
    Jan 2, 2013 at 0:45
  • What brand and model is your laptop, or more interesting, which sound chip does it use?
    – epistemex
    Jan 3, 2013 at 0:58
  • @Ken-AbdiasSoftware I updated question with system info
    – Giannis
    Jan 5, 2013 at 22:29

4 Answers 4


I'm afraid you are stuck as the Realtek chipset doesn't have a dedicated ASIO driver.

As tomeoftom's mention in his answer, you can use the Asio4All.

This will give you the ASIO interface but not necessarily the low latency that comes from using a dedicated ASIO driver. This is because Asio4all is more a interface "wrapper" than an optimized driver - it fools the system into thinking there is an actual asio driver for your card there (but it works).

However, minor tweaking is possible with it such as buffer sizes and adjustment of internal latency to get most out of your ordinary drivers which is use in the end. I recommend to test different settings here, playback and adjust again to find the optimal settings for your setup.

What this means is that it (Asio4All) can help with the problem, a little, hopefully enough to make playing the keyboard less annoying.

The greyed-out box just indicate that Sibelius is looking for an ASIO option but doesn't find it. This will change with Asio4all installed.

  • 1
    Greyed-out boxes are the worst design in the world, not least because they never tell you why they're greyed on mouseover.
    – iono
    Jan 6, 2013 at 4:08
  • This worked. Latency got lower using Asio4All. Although I am not sure how the really small buffer size(64 compared to 4096 with old settings) is going to affect the sounds(no problems yet) and also while Sibelius is open, no other applications can produce sound.
    – Giannis
    Jan 7, 2013 at 23:57
  • That's great. A small buffer reduce the latency but can become a problem if there are a lot of instruments and effects that need to processed and the cpu isn't able to deliver to the buffer fast enough. The sound will start to break up.
    – epistemex
    Jan 8, 2013 at 4:14

I solved this by making keyboard it self is the only output device, Synthesia will use the synthesizer in the keyboard which is a hardware thus is faster. and u will hear the sounds on the Keyboard speakers. No delay at all.


See if Sibelius supports ASIO drivers (look for Asio4All for an implementation that should work without a dedicated soundcard). If your keyboard also has MIDI Out, maybe a MIDI-to-USB converter cord will be better for latency - the Roland UM-ONE, which I use and works great for Ableton, is 35-50AUD on Ebay.

  • The Acorm masterkey 49 does not have MIDI-out it is MIDI-over-USB only.
    – RedGrittyBrick
    Jan 1, 2013 at 17:29
  • Ill check that as soon as possible.Any suggestions for external sound cards?
    – Giannis
    Jan 2, 2013 at 0:46
  • Updated question. Sibelius supports ASIO but the ASIO option in settings of Sibelius is greyed-out.
    – Giannis
    Jan 5, 2013 at 22:30

Very simply put, this signal over USB A connection will take time to bus, and with each step adding more latency, there is nothing aside from the following measures which will fix it.

  1. Buy faster RAM. Faster ram means less read write time between button press and sample playback.

  2. Dedicated soundcard. Frequently, a independent sound card will shorten the signal chain in the box and most importantly encode the signal locally.

  3. (Easiest of all) upgrade cables to USB type C and use 3.0 bus. The difference is 100% latency free playback. (I think there may be 2 milliseconds on slower machines, which is for audio, and even then it's suitable for vocal monitoring. In any case, the cable itself is to blame, and nothing onboard the PC can change that. The signal you are sending is pretty small, but how fast the actual copper wire responds to electrification is most likely to blame. Silicate is pretty fast, so with any reasonably up to date system this should be your go to answer for everything latency related. In short, if it can carry a mastering grade vocal sample, it can carry a MIDI note.

  • This answer is internally inconsistent. You say simultaneously that it is and isn't the computer's fault and also that it is and isn't the cable's fault. Also, saying RAM will make a difference for minimal data transfer associated with MIDI is just goofy.
    – AJ Henderson
    Sep 2, 2017 at 15:55
  • 1
    I agree this is a confusing answer, but I just want to point out that cables and USB port version ARE important and other answers did not mention them. I think a full rounded answer should list all posible causes of MIDI latency in order of importance/signal time dilation. At the very bottom could be more RAM.
    – Sanxofon
    Feb 15, 2020 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.