2

I have been dealing with this problem for a few months now without any success and I was wondering if anyone has ran into this issue. The scenario I'm about to describe used to work flawlessly without any hitches, but for some reason a few months ago it stopped working. Also, when I open up the Amplitube standalone application, things work just fine. This problem only occurs with the VST. Other VSTs work just fine in the same fashion, just Amplitube doesn't work.

Basically, I want to control Amplitube VST using Ableton Live by routing the MIDI messages from a MIDI controller to the Amplitube VST. This sounds fairly simple, but I found a few things have to be set before this will work:

  1. To change an Amplitube preset, a MIDI Program Change (PC) message must be sent to it. In Amplitube, if you click the little MIDI button on the bottom right and go to the Preset tab, you can change which PC message (PC 1, PC 2, and so on) the currently selected preset will be activated by. So I have set my preset called "Blues Drive" to be activated by PC 1.

  2. The global receive channel for Amplitube must be the same as the channel on which the PC messages are being sent. This is also in the MIDI settings but under the Global tab. Mine is set to channel 8.

  3. I have an FCB1010 controller that I have programmed to send PC 1 on channel 8 when I press a button. When I have Amplitube running as a standalone, and set the FCB1010 as my MIDI device under settings, hitting the button on the FCB1010 changes the preset to Blues Drive successfully.

With the above scenario set up, you would think that all you could have to do to control the preset using Ableton Live is to route the MIDI messages from the FCB1010 to the Amplitube VST. So I opened up Ableton Live and then started routing the messages by doing the following:

  1. Add the Amplitube VST to an empty audio track - call this AudioTrack1.
  2. Create a new MIDI track that will act as the "router" for the message from FCB1010 to the Amplitube VST. Call this track MIDITrack1
  3. Change the "MIDI To" dropdown of MIDITrack1 to AudioTrack1.
  4. Set the monitor for MIDITrack1 to "In"
  5. Set the monitor for the AudioTrack1 to "Auto" (this step is technically not required).

The way this works is that MIDI messages coming into MIDITrack1 will be sent to AudioTrack1 and since Amplitube is the only device loaded under AudioTrack1, it will receive the messages. When I hit the button on the FCB1010, I see that the MIDI track lights up telling me that it is receiving the message. But I don't see any change in the preset selection in Amplitube.

The weird thing is that if I follow the same procedure but use Guitar Rig VST, the presets respond just fine. They change when they should and they go to the correct presets. This leads me to believe that there is something wrong with Amplitube's configuration.

I've tried this scenario with many different settings and I've even completely uninstalled (including registry entries and all folders) and then reinstalled Amplitube multiple times, but this just does not work. I've tried using different MIDI controllers and different channels. The only thing I'm short of trying is to set up the entire scenario on a different computer. But before I went to that resort, I wanted to see what input this community can give me about this issue.

Please let me know if I've not made something clear. Thanks to anyone who is able to help in any way.

1

I might have an actual answer this time. Be sure you are doing a "Save As" a preset (not a patch) after assigning the program change number to your preset. This seems to have been the last piece I was missing in my setup for changing Amplitube presets within Ableton by sending MIDI program changes from the SoftStep pedal.

As I mentioned before, you will also need to have Amplitube set to MIDI channel 1 in its global MIDI options because Live passes everything along on channel 1 regardless of which channel it came in on. For example, my MIDI track is set to listen on Channel 11 for the SoftStep and sends MIDI to Amplitube. It's all on channel 1 by the time Amplitube sees the MIDI.

  • Thanks for looking into it. I'll try this out and see if it works for me. – Anshul Jul 7 '14 at 3:01
0

Not much help, but I can confirm the problem. I set Live's track routing as described (correctly), but no dice. I can see the MIDI track meter light up showing that a signal is being received, yet Amplitube does not respond to the program change message.

I've learned that Live throws out all MIDI channel information when it passes the MIDI on from the MIDI input track to the Audio track (or other MIDI track) containing the VST you want to control. So, keeping Amplitube set to listen/receive MIDI channel 1 is the way to go. You can still use the MIDI track input to filter out messages on a specific channel, but it will all look like channel 1 at the final destination. This seems like pretty stupid handling of the MIDI data.

I'm working on setting up Live and Amplitube for live guitar playing with a SoftStep and BCR-2000. Basically want to use the SoftStep to switch presets and trigger Live's Looper and the BCR-2000 for tweaking the sounds on individual presets. It's been a huge pain so far - a great argument for dedicated hardware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.