I have a Lexicon Lambda which I use in Ableton and Audacity. Latency is hardly an issue in Audacity, but I can't seem to get it down to a manageable state in Ableton, no matter how many different setting I tweak. I used to use a Behringer BCA2000 and had minimal latency issues in Ableton, but Behringer stopped supporting the BCA2000 and there is little in the way of Vista or Win7 drivers.

  • Are you using ASIO in Ableton with your Lambda? If you're using WDM or DirectX, that'd be the first thing I'd try.
    – Warrior Bob
    Commented Dec 8, 2010 at 2:24
  • N.B. The program is called 'Live', the company that makes it is called Ableton. Calling it Ableton is like calling Pro-Tools 'Avid'. (Not trying to be pissy, just trying to clear that up (I do it all the time too))
    – Ed J
    Commented Dec 8, 2010 at 17:32
  • Gotcha...yeah, I think Ableton really only makes Live and products that plug-in to Live...just assumed people would assume that as well. But, what would probably be helpful is to clarify the version...it's Live 5. I'll double check on the ASIO4All drivers...the Lambda supports ASIO4All so that sounds like what I need to verify first. Thanks for all of the help!
    – brian
    Commented Dec 9, 2010 at 20:16
  • @Ed J you're quite right. Calling it "Ableton" has become a habit because people get confused when I say "Live" in person and they of course can't hear the capitalization :)
    – Warrior Bob
    Commented Dec 9, 2010 at 22:15

3 Answers 3


Have you looked into ASIO4All? It bypasses a lot of the software-side signal processing and can reduce latency a ton.


If you're using ASIO already you're pretty much at the limit of Ableton Live's (current) ability to handle latency.

However, there are a couple of things you can try. Firstly, you could try to lower the buffer size of your card. This can help a lot, but I've never had too much success with this method, you get audible artifacts if you set it too low, and it can mess with your CPU usage.

Secondly, you could just do any tracking by utilising the 'direct monitor' option of your sound card (I'm pretty sure this is possible with your lexicon). This way the signal is bussed straight from the input to the speaker outs of your card as well as going into Live. This allows zero-latency tracking and is a common option where your DAW-of-choice doesn't support it.

The third option is to use Live's built-in 'delay' function. This will allow you to set a delay on a track-by-track basis, so that MIDI devices and outboard gear can be synced a little better. This is an option on the right-hand-side of the screen, below the IO button. This is useful for outboard gear (I have to use it for my ROMpler), but if you're intending to track or finely manipulate settings in real-time it's not much help for higher delays.


Latency is not an issue of the particular software, but of the sound card drivers. An ASIO driver means the audio goes straight to the sound card instead of going through the operating system. In windows, for example, I've managed to reduce my latency from 44ms using the normal driver, to something like 5ms. The downside is, the operating system can't do a mix of each application's sounds, so when I have some program that uses ASIO, all other sounds are muted. Also, in my case, when an ASIO application starts, it "asks the operating system for permission", so if there's something else making sounds it will refuse to work (typically I have to close Windows Media Player in order to run Propellerhead's Reason. If I don't, then Reason can either choose the normal 44ms latency driver or nothing at all). ASIO4ALL, like another user suggested, is a really good choice as it seems to support many cards. Note that installing an ASIO driver for your card will not uninstall other drivers, so you can still use the OS' regular way of doing things (which is what allows WMP and say Chrome to output sound at the same time).

  • Probably worth mentioning that ASIO is a Windows thing. The equivalent for Mac OS is Core Audio. I don't know what it is for linux.
    – Warrior Bob
    Commented Dec 9, 2010 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.