So I upgraded from Cubase SX3 on XP Home to Cubase 5 on Windows 7. Groove Agent went in just fine. Then came Guitar Rig 2 and the mixer in Cubase won't load in any reasonable amount of time. Go make a cup of tea and a sandwich and enjoy both and it might have loaded, with all manner of things 'not mapped'. It was all fine before Guitar Rig 2 went back on the hard drive, any thoughts?


Guitar Rig loads fine on its own. When I change patches there are different types of hum. The trouble comes when Cubase becomes involved. Cubase without Guitar Rig is fine. When instances of Guitar Rig are involved, things are as previously described.

Also tried installing SX3 as well and the same trouble exists in both. I tried changing the properties of Guitar Rig's .exe file so that it opens as if in XP sp2 and that's no good either.

Wondering if there is some kind of security problem with the various dongulators or if Windows 7 simply doesn't like Guitar Rig 2. Tried XP Pro sp3 as well but there are all manner of troubles with drivers for the motherboard as it is fairly new.

  • Does the same thing happen even without loading Guitar Rig up in Cubase? Does the mixer still take forever to load if you so much as have Guitar Rig installed? The only other factor I can think of is that you have moved to Windows 7. Are there any known incompatibilities with your software or your hardware on that OS?
    – Warrior Bob
    Apr 14, 2011 at 22:29

2 Answers 2


This is actually not the solution for you but a way you might find the solution on your own:

Go and grab Process Monitor. This will monitor every action any process does on your system. Check what Cubase does during the mixer load up.

Here is also a blog post which may help you get started with Process Monitor: Mark Russinovich - The Case of the Slow Logons


Here is one who had a similar problem. Perhaps the solution works for you: Cubase 5 won't open projects with Guitar Rig after update 5.5.2


We have latest versions of Cubase and Guitar Right in Windows 7 with no problems, in fact it is much faster than the old Win CO setup we had.

So I think you just need to look at processes as per Eduard's post. You could have a clash somewhere, or an inadvertent time out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy