Recently picked up a brand new MBP (the new one w/ the Thunderbolt port). Upgraded from a Intel Core 2 Duo MBP (non-unibody). I have an old Tascam FW-1804 that works fine on my old MBP, but I can't get it to work on my new one. Here's what I've done...

  1. Picked up a FW 400 to 800 cable. Unibody MacBook Pro's only have 800. New MBP connects fine to an old FW 400 external drive, but "Audio MIDI Setup" could not see the 1804.

  2. Found out I had to start my new MBP in 32-bit mode by holding "3" and "2" on start up in order for "Audio MIDI Setup" & my DAWs to recognize the 1804. http://discussions.apple.com/thread.jspa?messageID=12207068

  3. "Audio MIDI Setup", GB, and Logic could now see the 1804, but it did not register any input sound.

  4. Tried upgrading the 1804 firmware to 1.7 on the new MBP. Took much longer than normal because the updater often kept logging a "FLASH programming error", and restarting its cycle, but eventually completed successfully. After the upgrade, all the lights on the interface stopped working, and input sound was still not registering in any of the DAWs.

  5. Fired up my old MBP, and re-updated firmware to 1.7. Went much faster with no "FLASH programming error"s. The interface's lights were restored. I tested the 1804 on the old MBP and it worked like a champ.

  6. Tried once again on the new MBP, and it still was not registering any sound from the inputs.

Both my MBPs are running the latest version of Snow Leopard. I don't have to start in "32-bit" mode on my old MBP even though it's a 64-bit machine.

I know I probably should take this up with Tascam support, but I've heard pretty bad things about their customer support. I also know that my 1804 is pretty old and I should probably upgrade anyway, but honestly I'm hoping to hold out for Thunderbolt interface. The whole USB/FW external audio interface industry really hasn't progressed much since I bought my 1804, and other than this lame compatibility issue, I see no reason to upgrade.

Hopefully somebody can help! Cheers!

  • And now the problem is that Lion enforces 64 bit operations and, i just tested, there's no way the FW-1804 can work with it. I sent Tascam an email asking for a 64 bit driver. Windows has both 32 and 64 bit drivers so why macs don't ? Let's see what they answer but it's a bad thing if they won't release an update because "it's discontinued". I'm not planning on sticking to Snow Leopard and the FW-1084 is a decent box, i like and i want to keep using it... standstill ? – user1053 Jul 4 '11 at 13:58
  • David, I am having a similar problem. What model of firewire 400-800 adapter ended up working for you? (Or was it just a bad individual item?). I have a Sonnet, and works with my DM-24 to connect, but not the FW-1804. I am in 32-bit mode, OS 10.6.8, on a mid-2010 Mac mini. Thanks! -jes – user7552 Feb 22 '14 at 22:38

D'oh. I found out the issue was w/ the particular FW 400 to 800 cable I was using. It seemed to work fine w/ my external FW 400 drive, but not the 1804. Just bought another. Problem solved.

After emailing and calling Tascam support, I had pretty much given up. They couldn't help me, and said there wouldn't likely be anything in terms of firmware upgrades for the 1804 since it's no longer in production/support. (It's still super lame I have to boot into 32-bit mode to use this thing)

Anyway, I decided to keep my old MBP around until I could make a move. When testing on the old MBP I was using a 400 to 400 cable. And didn't think much of it cause I had already proven that my 400 to 800 cable works w/ my external HD. I accidentally connected my 400 to 800 cable and got the same issue I was having w/ my new MBP. Feeling really dumb, I bought another cable off Amazon.

If want any advice from this post... just buy a few FW 400 to 800 cables until one works. Apparently, the cables can partially work. The cables are cheap enough I suppose.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy