I am trying to run my Casio WK-1630 keyboard into my computer using an m-audio midisport uno. When I plug it into the usb port, one green light on the uno starts blinking. If I press a key on the keyboard, the midi 'in' light blinks once but then will blink no more upon further key presses. A couple times it worked for about twenty seconds. Every time I pressed or released a key the 'in' light would blink, which I assume is correct behavior.

I have installed and uninstalled drivers from m-audio up the wazoo. I've tried new ones and old ones. At one point Reaper was actually listing an input midi device (even though the uno wasn't working, Reaper apparently recognized the driver).

I'm running XP service pack 3 on a desktop that I bought in about 2006.

Please let me know if there is more information I should provide.

Is it a setting on my usb port? Is there another driver I should try?

Thank you!

1 Answer 1


It is possible that the Uno is not receiving enough power from the PC to operate. Sometimes the front USB ports on a computer don't put out as much power as the rear USB ports.

If you are using a desktop computer try plugging the Uno into the ports on the back of the computer.

Also, look at this question and the comments on it for some additional information about MIDI interfaces. The Uno is specifically mentioned in the comments:

I've got an M-Audio Uno and I'm having some problems with it. Not yet totally sure the blame lies with the Uno but it's looking probable, and there are quite a few negative reviews and reports of issues with this device...

There is also the possibility that the device or the port it is plugged into is bad. You may want to contact customer support and see if they have any additional suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.