I've been experiencing this problem with Logic Pro 9.1.8, downloaded from the Apple App Store. But Googling around suggests other people have similar issues with earlier Logics and with physical install CDs/DVDs.

Anyway, after installing Logic and all of downloading all the instruments and loops from the "Download Additional Content..." menu item, I found that some of the downloaded samples did not work. In particular:

  1. I'd click on an affected samples in the Library, I'd get a message along these lines: "ESX Instrument: Piano & String Layer: 16n7aD#3.wav file not found."

  2. I'd have a choice to either continue or search for the file. Search proved pointless, since if I clicked search it would just ask me the same "continue or search" question again.

  3. If I clicked continue, then it would apply the same in question to my current track. BUT that sample would be messed up. In particular, while some MIDI pitches/volumes would play, there would be a certain range of MIDI pitches/volumes for which the sample wouldn't generate any sound. (Which makes sense because one, but not all, of the wav files for the sample was missing.)

The result was having a number of samples that only half-worked, which seemed annoying.

In my case, I noticed that I could get the same wav-not-found messages inside my GarageBand '09. In particular, if I went into my Jam Packs in GarageBand (the Jam Packs that Logic had downloaded) and clicked on one of the samples that was messed up in Logic, then GarageBand would also give me a message about wav files missing inside esx files.

1 Answer 1


There are lots of different answers to this sort of problem on Google. The way I finally solved it was by doing all of the following:

  1. Upgrade from OS X 10.6 to OS X 10.8.2 (Mountain Lion)
  2. Redownload Logic. (First drag Logic to the trash, and then redownload from the App Store.)
  3. Inside Logic, redownload all the content from the "Install Additional Content..." feature

Some people apparently had success by only doing #3, but I tried that several times without success.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.