I'm having trouble using the "M-AUDIO Fast Track Pro" USB audio interface to record with.

I've tried to manually adjust the latency in the M-AUDIO Fast Track Pro Properties but the slider is locked at 256 and won't let me adjust the value.

No matter what I try, there is a latency issue present when trying to use M-AUDIO USB Audio Interface to record properly without lag.

How can i fix this issue?

Thanks in advance

  • some audio interfaces wont allow the value to be adjusted if the device is in use. Are you using it with particular recording software/DAW?
    – richaux
    Commented Aug 20, 2012 at 15:29
  • audacity - already tried to adjust latency in there though
    – CheeseConQueso
    Commented Aug 20, 2012 at 21:59
  • @richaux: is it possible that, when the device is set as the system default, it is then "locked"? Should the OP check to see if the device is the primary audio device and if it is, set the other sound card as the primary?
    – horatio
    Commented Sep 19, 2012 at 21:02
  • @horatio, I'm not sure!! My comment was based on experience with a different M-Audio card and Cubase, whereby changes in card parameters affecting latency were not allowed when Cubase was in use (unless Cubase's "release in background" option was set). However, for my setup I was able to change the card settings freely when Cubase wasn't running, even though it was the system default.
    – richaux
    Commented Sep 20, 2012 at 8:32
  • 1
    Is it possible that the FTP's buffer doesn't go below 256? I remember my M-Box-1 couldn't go below 512, which was why I sold it.
    – Robert
    Commented Dec 18, 2012 at 15:22

4 Answers 4


The problem may be less with the hardware and more with your choice of software; Audacity isn't exactly professional-quality, and it doesn't come with ASIO support out of the box for licensing reasons. See http://wiki.audacityteam.org/wiki/ASIO_Audio_Interface for more information.

  • This is right. The low latency features on your Audio Interface will not really get to shine without using the ASIO drivers.
    – user1167442
    Commented Apr 10, 2013 at 1:21

I had this same problem using the M-Audio Driver. I did find a fix for this problem. This will, of course be dependent upon a couple of factors. The speed of your computer and the speed of your USB audio device (2.0, 1.0, etc.).

I was able to get 64 samples with my M-Track and this should work for your Fast Track (and just about any other USB device).

  1. Uninstall all drivers. All of them. Yes, all of them. At this point your USB device should not be recognized by windows. This is OK.
  2. Go to Start->Control Panel->Hardware and Sound->Device Manager
  3. Find your uninstalled audio device, (it should have a yellow exclamation sign on it).
  4. Right click on the device and select "Update Driver Software...".
  5. Select "Browse my computer for driver software"
  6. Select "Let me pick form a list of device drivers on my computer".
  7. Select Manufacturer->(Generic USB Audio) and Model->USB Audio Device
  8. Click Next and then Click yes on "Update Driver Warning", yes its OK.

Under "Sound, video and game controllers" your audio device should now show up as "USB Audio Device".

  1. If you have made it this far, now install ASIO4ALL with the offline settings checked.
  2. Open your app and select ASIO driver, open the control panel for ASIO4ALL and move the slider to 64 samples.
  3. Check latency.

This worked for me without any problems. The only caveat is that with the generic USB driver loaded, your device Input/Output names will also be generic in your apps. My M-Track input tracks are named "Port_#0001.Hub_#0003 1/Port_#0001.Hub_#0003 2".

This is because the driver input and output info is installed when using the factory drivers, but ultimately this is not a problem since the tracks are still numbered, just something I wanted everyone to be aware of.

Hope this is of help out there.


It sounds like a driver issue, as M-Audio kit tends to have incredibly low latency. Go to their site and check out the latest ASIO drivers - you may need to reinstall them.

  • thanks, i did that last night but not too sure if i correctly installed and applied the ASIO drivers... can you provide more info?
    – CheeseConQueso
    Commented Aug 19, 2012 at 18:08
  • Did you get any improvement?
    – Rory Alsop
    Commented Dec 17, 2012 at 17:34

Adjusting your latency is simple

  • First switch off all the running programs such as cubase,nuendo etc.
  • Then go to Control Panel -> Sound Device and adjust latency to the desired value.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.