I'm quite new to After Effects, anyway I have an After Effects project with a composition that has an audio layer.

The audio is a .m4a file (recorded from Samsung Galaxy S4).

The composition is about 5 minutes long in total, however when I try to do a RAM Preview it only buffers about a minute or two max that I can play back to test if it works OK. The audio plays back in the RAM preview.

When I add the composition to the render queue, I set it to render as H.264, which has Output Audio ticked (I've checked by clicking on the options pop-up and even unticked and ticked again for Audio). Audio is set to 48.000 kHz, 16 bit, Stereo. No other settings were changed.

The final output file is .mp4 and does not contain any sound. I'm playing back with VLC player but it's always silent...

  • Very odd, that should work if you have the Audio checkbox ticked on the render settings. Does it work on any other formats?
    – AJ Henderson
    Dec 2, 2013 at 0:05
  • What do you see if you examine the .mp4 file using a tool like MediaInfo? mediaarea.net/en/MediaInfo/Download
    – Jim Mack
    Dec 2, 2013 at 1:28

1 Answer 1


Convert the m4a file into a 48kHz WAV file first, using iTunes, Audition, or QuickTime Pro. Import the wav file into AE, and position it in the same place as the video file. Make sure the loudspeaker icon is enabled on your new audio track.

  • 'position it in the same place as the video file' -> Wait, could this be why it's not "working" ? Although I've not yet converted it to WAV yet, but I move the sound file to be started about 20 seconds into the video (and sound ends before the end of the video).
    – dan2k3k4
    Dec 4, 2013 at 8:40
  • Convert it to a WAV first. Check the waveform on the audio track in AE. Make sure the music starts on the frame you want.
    – tomh
    Jan 5, 2014 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.