Hey all,

I have been having trouble when backing up and copy my SFX Libraries that I have purchased from 1 drive to another. The error I get is that I need permission to perform this action, You require permission from Administrators to make changes to this file.

I have administrative permissions on my system and am just kind of lost now.

  • All the the files I cannot move or copy seem to appear Green in explorer. May 7, 2012 at 15:01

3 Answers 3


I ran into something like this with MacDrive. In older versions of MacDrive (version 8, on WinXP) SD2 files could be moved around just fine even to NTFS drives, no issue with permissions either. Then I upgraded to Win 7 with MacDrive8, discovered that in this case if I even so much as TOUCHED an SD2 file to do anything other than reading the file, the resource fork would become destroyed and the file useless, but there were still no permission issues.

Then I upgraded the MacDrive 9, the problem persisted and after some pleading they give me a registry update to test out. I ran it, and the Sd2 problem was solved, they could be moved anywhere and the resource fork was fine. But then sometimes I would run into a permissions problem when copying files from one drive to another - this was new. After some troubleshooting with them we discovered that when the Sd2 fix was applied, it disabled Zone management (e.g. handling files which are flagged as originating from somewhere outside of your computer drive, hence permissions management problems). They sent me a registry fix to un-toggle it again, and the Sd2s were problematic but the permissions fixed. So in the end they provided a set of registry 'toggles' to allow me to switch between the modes as needed, between needing SD2s to function correctly versus having no permissions issue. It was only some files that kicked permissions issues, and going into the Properties and clicking 'Unblock' would fix it from even happening whether the fix was applied or not. The catch is though that there doesn't appear to be a folder-level/batch Unblock control so you either need to have Zone management function properly or hand-find every single file which needs to be unblocked. Hoping to get these SD2 converted then be able to re-enable the Zone management so permissions are never an issue. Until then, I have to toggle between the two MacDrive modes. If you have MacDrive and suspect this could be a cause after seeing if Shaun's comment does anything to fix it, I'd be happy to send the registry toggles you're way to give it a shot (they're for v9). Based on what you provided for info, I'll bet Shaun's answer is the one the go by.

Just my 2 cents though given that this is the only permissions issues I've run into on Win 7. Can't say I've ever seen green filenames so my comment may not even apply.

  • I do have Macdrive. But this error is occurring on 2 non Mac Drives. May 7, 2012 at 17:22
  • @Michael the permissions issue actually affected any and all drives (even NTFS), so it wans't an HFS+ only type thing. May 7, 2012 at 18:46

That sometimes happens in Windows with files from OSX; usually ones that have been compressed on a Mac and later extracted on a PC. Go to the highest level parent folder you can (but one that is still green in the explorer), right-click that folder and select properties. Somewhere in the properties dialog, you should be able to find a selection that has to do with encryption (that's what the green filenames mean). Un-encrypt the folder and allow it to apply changes to all files and subfolders. That should take care of your problem.


Just remembered that the encryption attribute is in the "Advanced" menu under the "General" tab in within file properties. So, look there.

  • @Shaun All of the files that are causing problems do look like they have originated on MAC OS. They all contain a folder that says _MACOS. Even going into properties and advanced, it still is not allowing me to change those permissions. May 7, 2012 at 17:19
  • @Michael Gilbert - weird. i've had this happen before and that fix has always fixed it for me. (right-click, properties, "General" tab (I left this mention out before), "Advanced" button, and uncheck "Encrypt contents to secure data." are you not able to change the encryption status, or just not move them after making the change? are the files still appearing in green in explorer? May 7, 2012 at 17:32

From what I have found online, it seems there is a permissions problem with .zip files created using Mac OS and then unzipped using the built in windows zip utility. When you unzip them, all the files from within the Mac OS zip extract with errors in their permissions no matter what settings you modify after the fact.

  • I had some new files with the same issue the other night. I went through process I described earlier in this thread, and it worked without a hitch. Are you sure you it doesn't work for you? Did you forget to click "apply" or something? May 23, 2012 at 18:47
  • @Shaun Every time I attempt to change the encryption I get an access denied window saying I need to provide administrator privileges. May 24, 2012 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.