Take the 2-minute tour ×
Sound Design Stack Exchange is a question and answer site for sound engineers, producers, editors, and enthusiasts. It's 100% free, no registration required.

I downloaded Native Instruments Kontakt 7 Player, and despite the fact that I'm on an AMD Athlon 65 3500+ 2.19 GHz with 2.5 GB of RAM, the sound quality is unacceptable; there are drags and buzzes and everything while playing any patch. So much for thinking of running it on my laptop with 1 GB RAM and less than 2 GHz CPU...

Does anyone know how to improve the performance? Thanks in advance.

(side note: Propellerhead Reason seems to have lower requirements, I'm downloading the demo of that now too..)

share|improve this question
add comment

migrated from avp.stackexchange.com Jan 27 at 15:05

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

2 Answers

"Drags" and "buzzes" sound to me like a buffer problem. While this isn't necessarily part of Kontakt per se, it is sensitive to your free computer resources and perhaps Kontakt (combined with whatever software you've got going in the background) has used up enough resources that it's becoming hard to keep processing the buffer. This problem isn't uncommon in audio environments due to the desire for low latency times.

Since you're on AMD, I'm presuming you're running Windows, which means you're probably using some kind of ASIO driver for low-latency audio. Somewhere in that driver or in your recording software should be a setting called "Audio Buffer" or "ASIO Buffer" or something to that effect. Generally this number is a power of 2, although it doesn't strictly have to be.

Try raising this value. This is the number of audio samples kept buffered before they're sent out to the hardware. The higher this number, the higher the latency time (because of the larger buffer to fill) but the more resilient the system is to temporary losses of resources - if something else is tying up the CPU, you've got several milliseconds of buffer to burn through before you start getting audio interruptions.

share|improve this answer
    
Thanks. I was using DirectSound with a normal sound card. Kontakt does allow you to raise the buffer size (default to 512 samples) but raising it didn't help. // I then downloaded ASIO4ALL, which also defaults to 512 samples, and set Kontakt to use it, which actually got rid of the buzzes. But instead, there are now 'breaks' in the music, short pauses of silence. Any way to fix that? Thanks in advance. –  Fred Apr 12 '11 at 15:45
    
Again, I'd say raise the ASIO buffer with your new driver, and see what happens. It still sounds like a buffer problem. It's certainly possible that it's something more subtle than that (maybe something is up with your hardware?) but I wouldn't know what else to do besides try a different sound card. –  Warrior Bob Apr 12 '11 at 17:18
add comment

What sound plugin are you using? Also, you could try to adjust the buffer, I've heard somewhere around 480 or so is good, although I believe the higher the better; so 1024 or so. Edit: Also what software are you running it on?

share|improve this answer
    
Not sure what you mean by plugin; I was playing Kontakt's drum kits, Rock Guitar sample, and Ragtime Piano sample. I ran Kontakt Player stand-alone as well as briefly in the Kristal DAW. About sampling, see my comment to Warrior Bob's post. –  Fred Apr 12 '11 at 15:49
1  
Cool, yeah I would suggest using asio also; anyway, are you planning to record the music you make with Kontakt? –  James Litewski Apr 12 '11 at 22:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.