Take the 2-minute tour ×
Sound Design Stack Exchange is a question and answer site for sound engineers, producers, editors, and enthusiasts. It's 100% free, no registration required.

So I am trying to stream my setup to Mixlr, which provides a streaming interface where I can assign an audio device to send to the stream. There are a few options in the dropdown menu for each of the Scarlett 18i20's output channels, and there is one for the Scarlett 18i20's USB channel. Now I can hear both the audio from the Ableton Live DAW and the external instruments I have plugged into the audio interface, but I can't seem to get any audio from the USB channel, and the only time I do get audio from the interface to the Mixlr stream is if I select the 18i20's channels 3/4, which is the input channel used by the external instrument.

Has anyone successfully been able to get the USB audio source from a FocusRite audio interface to provide audio to the USB device? How do I get this to work? I need to feed to the stream both the external instrument and the audio tracks within the DAW.

share|improve this question

migrated from avp.stackexchange.com Jan 25 at 9:36

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

3 Answers 3

I had a few problems with this, but it all comes down to how you use MixControl. Basically MixControl is like an intermediate patchbay between Ableton and your interface. Look under the loopback source, and see where that is being routed. My guess is that it is set to DAW (or input?) 3/4. Change that to an unused one, and use that is your input channel for Ableton.

Let me know is that works!

share|improve this answer

If you're on a Mac, you can use Soundflower from Cycling '74. It allows you to virtually patch between programs and devices, and it's free.

I've never tried it, but JACK seems to be a similar application for Windows.

share|improve this answer
    
No, sorry, unfortunately I am not on a Mac. –  cj5 Jan 27 at 17:35
    
Then I'm out of ideas. I work with Ableton, and I'm not familiar with either of the devices you mentioned. Hope someone else can help you out. –  Shaun Farley Jan 27 at 19:33
    
@ChrisWalsh - just found out about a program called JACK for Windows. It seems similar to Soundflower, and it may solve your problem: jackaudio.org –  Shaun Farley Jan 28 at 4:04
    
Shaun, thanks for your help. I have used JACK before, but I don't think it's what I need. JACK is for creating virtual audio devices, and the FocusRite Scarlett 18i20 is an external audio interface that acts as its own mixer/soundcard. It's hardware in contrast to software. Ableton Live has access to this hardware, as I can hear the audio from it thru the audio interface, but I cannot get it to assign to an output on the device for streaming. –  cj5 Jan 28 at 17:42
  1. Try the audio routing in Ableton and your system preferences. Sometimes channels are deactivated.

  2. If nothing else helps, try the program Pure Data. Its a freeware version of MAX and it allows you to freely route audio and midi in your computer/mac/unix. You will need to watch some tutorials so.

share|improve this answer
    
I'll look into that. I basically want the Master outs to be available to Mixlr inputs. In Ableton Live, the Master channel output is on channels 1 and 2, but for some reason, everything above those (i.e. 3/4 and up) are only available to Mixlr as an audio source. I think the Scarlett is leaving those channels reserved for something else. –  cj5 Feb 27 at 21:39
1  
Look up the System preferences of your audio interface. Sometimes You Need to activate the channels there. Also Check audio preferences -> Channel config in ableton and activate Channel 3-4 –  Tobias Schmidt Feb 27 at 23:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.