Take the 2-minute tour ×
Sound Design Stack Exchange is a question and answer site for sound engineers, producers, editors, and enthusiasts. It's 100% free, no registration required.

I'm running Windows 7 Pro 32-bit on my Dell Latitude 2100 netbook and I'm having an issue with the line in device/driver/functionality.

The device & driver are stock:

  • Driver Date: 7/13/2009
  • Driver Version: 6.1.7600.16385

My setup is bass guitar running through a 12' long instrument cable (1/4") with a 1/4" female to 1/8" male adapter into the line in port on the computer. Then the 15' long headphones/line out cable goes into a standard set of powered speakers.

I'm almost sure that the manufacturer of the on-board sound card is RealTek.

The problem is that there is latency (when monitoring input) between the source and the speakers.

How do I get rid of this latency?

Thanks for any help.

share|improve this question
add comment

migrated from avp.stackexchange.com Jan 25 at 9:36

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

5 Answers

"the line in port on the computer"

"I'm almost sure that the manufacturer of the on-board sound card is RealTek."

DAW recording 101: on board sound cards are useless

On board sound cards, the one that comes built into your motherboard is designed to make beeps and whistles and now-a-days telephony. It is not designed for high qualily, low latency sampling.

No matter what machine you have, you will get very poor performance with an on-board sound card.

With Windows, you'll need a sound card with ASIO drivers that was designed for studio use. It doesn't have to be mutli-channel, or even high bit/frequency sample rate. But it needs decent ASIO drivers. If you want to record good quality, you'll need something with decent AD converters that can sample high bit rates at high frequency.

DAW recording 102: get a decent machine

It's not so much that the netbook is under powered for sampling. It's that it probably has cheap/poor quality components. I'm specifically reffering to the either the lack of firewire or a cheap chipset. USB will almost never achieve low latency. The way zero-latency monitoring is done with USB devices is the sound is monitored before it enters the USB bus. This is a good solution. However, you will not be able to hear any FX. Also, any software synths or samples will become difficult to play.

The reason why you can acheive lower latency with firewire is because firewire has it's own dedicated processor and in turn also puts less load on the CPU. However, poor qulity firewire controllers have their own set of problems.

If you are only recording one instrument at a time and you don't want to play software sythns/samplers, you could do fine with a stereo USB sound card and your netbook. There are many with built-in mic pres for very cheap.

You might be able to also get some alternate drivers that may emulate zero-latency monitoring. However, this is highly unlikely simply because of the AD-bus-software-bus-DA round trip.

Windows Vista and later have considerable amount of overhead. If you want to have a well performing machine, use linux or Windows XP. Of course you could also shell out for an Apple, but if you know what you are doing, Apples offer no extra benefits.

share|improve this answer
    
thanks for the explanation –  CheeseConQueso Feb 22 '11 at 3:53
add comment

On Windows, get ASIO-compatible audio interface. Firewire or USB since you're on laptop.

This is the most proper solution to your problem.

You can try to install ASIO4ALL wrapper, which just lies to your OS and software that your internal interface can do ASIO, but it's considered a hack by any means. Your mileage may vary if you go this path, I went this path myself, and it can easily become unstable.

share|improve this answer
    
yeah, i saw someone mention the ASIO4ALL attempt and tried it myself with no success –  CheeseConQueso Feb 22 '11 at 3:54
    
Any news on this? I had trouble with ASIO at first but have since got it working fantastically. The main problem with ASIO is that only one program can capture your audio output at once. So, you have to close everything... then open your DAW/recording software. I have /no/ latency issues with my crappy on-board sound card, even with high CPU usage. –  RyanScottLewis Mar 19 '11 at 10:21
    
I recently had this same problem. I purchased a powered mixer by Behringer for like 130 bucks, and it has a firewire/usb3 interface to the PC. It is seamless. I love it. –  Barry Chapman Nov 8 '13 at 20:07
add comment

The latency is probably a result of having only a "soft" connection between the input jack and the output jack on your netbook.

I'm assuming you have selected "Listen to this device" from the Input properties of the "Recording Device".

This is unfortunately becoming more common with commodity chipsets as would be found in a netbook computer.

In older (even cheap) chipsets, there was an actual "hard" link between the input and output jacks that could be attenuated by using the "line" or "mic" level in the windows volume mixer. There was no A/D or D/A conversion needed and therefore no latency.

Because this "hard" link has been eliminated from the circuitry, the audio must be sampled via the A/D, routed through the Windows audio API, then decoded by the D/A and spit back out the output. This of course takes time, and leads to the delay you are noticing.

share|improve this answer
add comment

I use my computer essentially as an amp, but I did get mine working with live monitoring in Reaper while using realtek onboard sound. I have a much beefier setup than a netbook though.

The best (lowest) latency for me:

1) ASIO4ALL - must have you will NOT get low latency using WDM or DirectWhatever

2) set sampling rate to 96khz

share|improve this answer
    
Thanks for the input, guys!!! I use Mackie Tracktion, and recently I upgraded from version 2.0 to 4.x, and I couldn't figure out where the latency had gone. The settings had reverted back to the WDM (windows) driver. Once I changed it to ASIO, back to smooth sailing. -Tre –  Tre Powell Nov 8 '13 at 7:32
add comment

Welcome to the club :-). I had exactly the same issue and this is how i solved it. You basically need two setting changes to fix this latency.

1) Go to Control Panel->Sound->Playback. Open the properties for 'Speakers'. Go to 'Levels' tab and scroll down through the list of ports and choose your line in port. Increase the volume slider to 90%-100% level.

2) Go to Control Panel->Sound->Recording. Locate your line in port there(If audio is already coming in via line in, you should see a dancing bar). Open properties of that port and go to 'Listen' tab. Un-check 'Listen to this device'.

You should be fine now. I had zero latency when i tried these. BTW, i was trying with a digital keyboard.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.