Take the 2-minute tour ×
Sound Design Stack Exchange is a question and answer site for sound engineers, producers, editors, and enthusiasts. It's 100% free, no registration required.

I'm using Logic Pro 9 as a musician (mainly electric bass parts). However, this may be DAW-agnostic.

When editing, I often would like to move, repeat, and otherwise work on regions that are as small as two or four bars. The problem is that most of my regions end up making an audible clicking noise at the beginning and end, where I cut them.

This is my workflow:

  • Record some takes using cycle recording
  • Find and select the best take
  • Check if timing is ok using flex, eventually move something.
  • Cut to the desired length, using snap to beat/bar/whatever.

I understand precisely the cause of clicks: what it's not clear is how to avoid them. In the arrange window, the Snap Edits to Zero Crossings option in the Audio menu is (obviously) checked. This appears to have no effect whatsoever.

The sample editor is really a pain to use: by default it moves the anchor, and when unlocked it messes up the Flex edits: I see flex markers moving with respect to transients and frankly I can't understand why. Moreover, undoing any change to the regions that happened because of work in the sample editor results in the selection changing, but not the region requiring an use of the selection->region command every time I want to undo.

So: what is the best way to just have those two bars I want without clicking noises on the start end?

share|improve this question
add comment

migrated from avp.stackexchange.com Jan 24 at 18:14

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

3 Answers

If I understand the issue correctly, it's because even with edges on zero crossings, you're often going from zero to full volume on that clip in the space of several milliseconds.

Several DAWs (I know Ableton Live does this, and I think Reaper does too, but I'm not familiar with the others) allow an option to put a 4-ms (or thereabout) fade in and out on audio regions like that. Often it works out pretty well, but for some things (comp tracks) it can cause somewhat noticeable drops in between region edges.

If Logic supports something like this, then enable it - if not, you can manually create a very short fade on the edges, although I realize this could get somewhat tedious.

share|improve this answer
add comment

When I cut and paste audio, I usually try to zoom in and do it at a zero crossing. If that is not possible, I will edit the wave form directly to eliminate the click. I know Audacity can modify the wave form, and I'm sure some other DAWs can do it.

It's a much more manual and time consuming approach, but I have had pretty good results.

share|improve this answer
add comment

While I'm not sure why you're having problems with the zero-crossing in the first place, it's easy enough to put a small fade on the beginning of the region to eliminate it. You can either use the Fade Tool to draw in the fade on the region, or select the region and look in the region Parameter Box (left sidebar). You'll see fields for applying a Fade In and Fade Out/Xfade in milliseconds, with optional curve.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.