Take the 2-minute tour ×
Sound Design Stack Exchange is a question and answer site for sound engineers, producers, editors, and enthusiasts. It's 100% free, no registration required.

When I record MIDI tracks in Ableton Live, is there any way to adjust it so the MIDI notes I record are automatically shifted to their correct positions, correcting for the lag time on my MIDI adapter?

I can easily adjust the latency for sync/realtime messages, but this setting has no effect on regular notes.

I am recording my Juno-106 both on MIDI and on audio, but I want to record the MIDI so I can go back and fix a note here and there, and then play everything back with the Juno correctly in time.

share|improve this question
add comment

migrated from avp.stackexchange.com Jan 24 at 18:30

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

3 Answers

up vote 1 down vote accepted

Unless you're doing epic synth solos chances are you could easily solve this problem using the 'Quantise' function.

Simply right-click in the piano-roll and select the 'Quantise Settings' option: this will allow you to quantise right down to 1/32note triplets (IIRC).

OR you can even turn on auto-quantise from the Edit menu (Record Quantisation), which will let you quantise what you're playing as you play it, which can be useful in a live setting if your timing is a little off.

share|improve this answer
    
Unfortunately, epic synth solos is what I use it for. Quantizing makes it too robotic sounding for me. If I could shift everything to the left by 20-30ms, I'd be in good shape. I'm not concerned about playing live.. that would be fine, as I am using the audio out of the Juno. –  Brad Dec 30 '10 at 18:54
1  
Ah, in that case I'd probably CTRL-A and drag a bit to the left while I hold ALT ;) Not exactly robust but I think it'll fix it. –  Ed J Dec 30 '10 at 19:05
add comment

It sounds like you have found the lag adjust, and you also need to make sure the latency settings for the audio card is correct.

Also, I have been plagued by a bug in several versions where MIDI recorded notes get a long lag if monitoring is on or off (I can't remember which) so make tests with that, turn off and on monitoring on the channel you record on. I don't have Live on this computer, so I can't tell you exactly, but fiddle around and see if it gets better.

share|improve this answer
    
This makes no difference on my system... and shouldn't anyway, unless the PC is way behind. –  Brad Dec 30 '10 at 22:11
    
@Brad: Well it does in some versions. It's a bug in Live, quite simply. If you aren't affected by that I don't know what the problem could be. There is latency adjustment, and it works, since at least Live v4 which was the first one I used. :) –  Lennart Regebro Dec 30 '10 at 22:20
add comment

If it's the lag time on your midi adapter, then the lag should be constant throughout the entire midi recording... so just select all the midi notes in the edit view, zoom way in and move the notes until you can hear it's where you want it.

As for doing it on the fly, or in real-time I don't think there's a way to automate that, though I could be wrong. I'm sure you could do it with Max, but that's usually the case.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.