Take the 2-minute tour ×
Sound Design Stack Exchange is a question and answer site for sound engineers, producers, editors, and enthusiasts. It's 100% free, no registration required.

I just bought myself a Tascam US-122 for recording my music. Setting up and recording guitar bits was easy enough but now I'm trying to add some piano. For this I have a Roland (E-36) keyboard that I connect though MIDI (in/out) on my Tascam.

It was looking good at the start; I could see that Cubase was receiving when I played something on my Roland. Problem is that I could not hear it through my headphones (that are connected to the Tascam) nor from my PC speakers when I select the Tascam as the output audio device. This does work when I do the same with my guitar.
If I select 'Microsoft GS Wavetable Synth' as output routing then I can hear the music from my speakers although sometimes with a delay (which as I've read has to do with buffering).

Any idea what I need to alter on my setup in order to hear the playback through my Tascam?

UPDATE:
not sure if this is related but I don't see the point (and I guess there should be a point) in connecting the MIDI output on the Tascam to the MIDI input of the Roland. I can hear the (original) music on my keyboard regardless if that cable is connected or not.

UPDATE2:
In the mean time (after reading many posts) I installed reaper but there I face the same issue: I can hear my keyboard (through the headphones that are connected to the Tascam) if I select Microsoft GS Wavetable Synth as hardware output device (but then there's the latency issue). If I select TASCAM MIDI as hardware output I hear nothing.

share|improve this question

migrated from avp.stackexchange.com Jan 24 at 18:30

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

    
    
I have the Tascam US-800, nothing but trouble, original driver caused my system to crash, updated driver better, but then CUBASE was impossible to get it to work right with the output routing. They had another option besides Microsoft--see if you have that other option and try it. Hope you have better luck than I did. Only using audio side not USB side until I see a better driver from Tascam. –  filzilla Apr 12 '12 at 22:44
    
@leftaroundabout: tx, I installed CVPiano, when I play a note in the program I hear it through my tascam but although I selected tascam as the MIDI input port when playing on my keyboard nothing is registered in CVPiano? Also, do you mean I should link CVPiano in some way with Cubase (as a VST or such)? –  Stijn Geukens Apr 13 '12 at 9:10
1  
Yes, as a VST instrument. You then route the keyboard's MIDI channel to that VSTi. –  leftaroundabout Apr 13 '12 at 11:04
    
Hi, I tried that but unfortunately it didn't solve the problem. I updated my post. –  Stijn Geukens Apr 13 '12 at 18:17
show 1 more comment

2 Answers 2

up vote 2 down vote accepted

It's hard to provide an authoritative answer to troubleshooting questions like these (they're kind of open ended), but I'll try and describe how I imagine the situation should look, which hopefully will be enough information to diagnose the problem.

First off, it's critical to understand that MIDI and audio are not the same thing. MIDI is an instructional code that doesn't produce any sound. Rather, MIDI messages can be interpreted by audio devices which produce audio based on those instructions (Microsoft GS Wavetable Synth is one such device). You likely already know this, but I mention it just in case.

As I understand the situation, Cubase, via the Tascam, is getting MIDI messages from your Roland keyboard, and must then must send those notes somewhere if they're going to mean anything. You've got three basic places you can send those MIDI notes in your current setup:

1. Back out to your keyboard

Connect the MIDI OUT from your Tascam to the MIDI IN on the Roland, and configure Cubase to send MIDI out that output. The audio will be generated by your keyboard and played through the keyboard. You'll get exactly the sound that you're used to from your keyboard, but it won't go through your headphones since that audio is not being routed to Cubase or the Tascam. You can solve this by connecting the audio out from the keyboard to the audio in of the Tascam. Of course you'll have to deal with a bit of latency since that's always present when dealing with digital audio, but that particular Tascam interface appears to have a hardware monitoring feature which might let you get around this.

2. Out to the GM synth

Select 'Microsoft GS Wavetable Synth' as the output routing, like you tried. Now the MIDI will be synthesized by whatever device that is, probably a built-in MIDI synthesizer on your computer's internal soundcard. The only problem is that the audio is probably only going through that soundcard, and not your Tascam. This is likely why you can hear it through your speakers, but not your headphones. Some soundcards may have options for routing this audio to different destinations (such as Cubase), but in my experience that is not generally the case.

3. To some synthesizer in Cubase

You've got MIDI data in Cubase. You could always route it to some synthesizer plugin. This is the most convenient option since it's all in software so you don't need to do any further routing, but you'll have latency to worry about, and the plugins at your disposal may or may not be the sound you want.

Something you may consider, no matter which of these routings you end up choosing, is getting a hardware audio mixer, and mixing the output of all of your sound sources (Tascam interface, Roland keyboard, internal soundcard) together, so you can hear them on one set of speakers or one pair of headphones. This is what I do in my little home studio, and it works very well for me.

share|improve this answer
    
@Bob: +1 for the excellent explanation! When you say ´You can solve this by connecting the audio out from the keyboard to the audio in of the Tascam.´ You mean the MIDI out or simply the headphone out? –  Stijn Geukens Apr 16 '12 at 7:48
1  
@TheStijn According to the manual the E-36 has two 1/4" output jacks on the back. These are the ones Warrior Bob is referring to. You can either hook up just the one labled 'mono', or both left and right depending on if you want stereo or not. –  Friend Of George Apr 16 '12 at 13:28
    
@TheStijn Friend Of George is correct. The idea is to route an audio signal out from the keyboard. Even if it didn't have those jacks though, the headphone out will work as well (but remember that it's stereo, and audio interface jacks are often mono) –  Warrior Bob Apr 16 '12 at 15:30
    
@Both Tx, I'll certainly give that a go if I can find a way to comfortably work with the MIDI interface. –  Stijn Geukens Apr 16 '12 at 15:46
add comment

There does seem to be an inherent problem related to mixing both a Midi controlled software synth and normal Audio through a USB device into Cubase to be recorded etc. From what I have experienced and gathered from stuff on the web, its a case of hitting a device one way system, you can't have it going both ways, so routing one will always take a longer path than another. Latency then through timings and interpretation from Midi to synth makes the whole thing messy, I haven't found a way round controlling a PC software synth with a midi keyboard through a USB interface and recording the PC's output in Cubase, as there seems to be a conflict with which program takes control of the device driver first to deliver the sound.

I can't even get Cubase to record the output from Steinbergs Legacy software on the PC, but thats just probably me.

If that makes sense to you, welcome to my nightmare.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.