Take the 2-minute tour ×
Sound Design Stack Exchange is a question and answer site for sound engineers, producers, editors, and enthusiasts. It's 100% free, no registration required.

This clock, with the output set to a "Numerical Readout" and the max of the numerical readout set to 44100Hz (or anything, for that matter), always displays 0. Either the clock's not working or the numerical readout is not working. When "always on" is selected, there is an X at the input terminal of the numerical readout.

Reaktor Patch

Here's the connection to the numerical readout: Readout

It definitely doesn't count too quickly. A clock set to count in seconds also displays 0.

share|improve this question

migrated from avp.stackexchange.com Jan 24 at 12:01

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

add comment

1 Answer 1

up vote 1 down vote accepted

You are building in an Event core cell which runs at a much slower rate than an Audio core cell. SR.C isn't active in Event core cells.

Create an Audio core cell, and build the same thing and it should work.

See the paragraph at the top of page 31 of Reaktor 5 Core Reference Manual English.pdf, which should have been installed with your copy of Reaktor:

As previously mentioned, event core cells are restricted to event processing tasks. Because clock sources are disabled inside them (see the table above), they cannot generate their own events and, therefore, cannot implement modules such as event-rate LFOs and enve­ lopes. When you need such modules, we suggest that you take an audio cell and convert its output to event rate using one of the primary-level audio to event converters

One more thing: don't forget to use a voice combiner (looks like this: }) before sending your signal to the display.

share|improve this answer
    
That's very useful information. I tried exactly the same thing with an audio core cell and I got exactly the same thing (it displays 0). I tried the simple clock, one that resets at 44100, and one that counts one per second and resets at 44100. The Numerical Display was set to 0 to 44100. Again, clicking "always active" displays a red X at the numerical display input. –  Jamil Jun 23 '13 at 23:23
    
You may need to use the monophonic voice combiner (looks like '}') in order to get the result to display. Displays are always frustratingly difficult to work with in Reaktor. –  ObscureRobot Jun 24 '13 at 3:31
    
That solved it! Thanks! –  Jamil Jun 24 '13 at 6:10
    
You can also make your entire synth monophonic, but then your entire synth is monophonic. –  ObscureRobot Jun 24 '13 at 6:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.