Take the 2-minute tour ×
Sound Design Stack Exchange is a question and answer site for sound engineers, producers, editors, and enthusiasts. It's 100% free, no registration required.

Have an M-Audio M-Track audio interface.

Upon electric guitar monitoring (jack plugged - guitar line input), there is a 24 ms lag (input + output). Reading on the internet, I see people getting lower latency values.

How could I achieve this with my setup?

EDIT:

  • Disabled some asio4all's unnecessary checkboxes (post started with 33ms)
  • Buffer bar doesn't seem to cause any changes when dragged

enter image description here

share|improve this question

migrated from avp.stackexchange.com Jan 24 at 12:01

This question came from our site for engineers, producers, editors, and enthusiasts spanning the fields of video, and media creation.

4 Answers 4

Why you are using Asio4All?

Try using the driver from M-Audio.

share|improve this answer
2  
M-Audio themselves state and recommend in the product's manual that asio4all gets better latency than their own drivers –  Gal Margalit May 10 '13 at 16:36
1  
@GalMargalit That's funny..you can try to lower the sample buffer size in your DAW. What DAW are you using? –  redreggae May 10 '13 at 17:28
1  
Ableton live, downloaded M-audio drivers: doesn't seem to change anything –  Gal Margalit May 12 '13 at 10:15

I had this same problem using the M-Audio Driver. I did find a fix for this problem. This will, of course be dependent upon a couple of factors. The speed of your computer and the speed of your USB audio device (2.0, 1.0, etc.).

I was able to get 64 samples with my M-Track and this should work for yours too (and just about any other USB device).

  1. Uninstall all drivers. All of them. Yes, all of them. At this point your USB device should not be recognized by windows. This is OK.
  2. Go to Start->Control Panel->Hardware and Sound->Device Manager
  3. Find your uninstalled audio device, (it should have a yellow exclamation sign on it).
  4. Right click on the device and select "Update Driver Software...".
  5. Select "Browse my computer for driver software"
  6. Select "Let me pick form a list of device drivers on my computer".
  7. Select Manufacturer->(Generic USB Audio) and Model->USB Audio Device
  8. Click Next and then Click yes on "Update Driver Warning", yes its OK.

Under "Sound, video and game controllers" your audio device should now show up as "USB Audio Device".

  1. If you have made it this far, now install ASIO4ALL with the offline settings checked.
  2. Open your app and select ASIO driver, open the control panel for ASIO4ALL and move the slider to 64 samples.
  3. Check latency.

This worked for me without any problems. The only caveat is that with the generic USB driver loaded, your device Input/Output names will also be generic in your apps. My M-Track input tracks are named "Port_#0001.Hub_#0003 1/Port_#0001.Hub_#0003 2".

This is because the driver input and output info is installed when using the factory drivers, but ultimately this is not a problem since the tracks are still numbered, just something I wanted everyone to be aware of.

Hope this helps!!

share|improve this answer
    
Thanks. What audio interface are you using? –  Gal Margalit Jan 28 at 7:21

Play around with the ASIO buffer size, assuming you're on Windows. If you're on OSX, it's Core Audio instead of ASIO, but same idea.

Generally, ASIO4ALL (and actually, any low-latency audio driver) will expose a parameter for how large the ASIO buffer is. The buffer is a buffered set of samples between your sound hardware and your computer. The idea is that as your computer jumps between tasks, as computers do, there's a safety net in case the computer doesn't get around to processing more sound data. This prevents audible clicks, pops, and start-stop stuttering when recording or playing back audio.

The shorter the buffer, the shorter the latency, at the risk of an interrupted signal. You can experiment with different settings to see how low you can get the buffer before your computer is too interrupted by general use to keep it stable.

I don't know exactly why this is, but different combinations of audio hardware and computers seem to have different minimum useful buffer sizes. As an anecdotal example, my previous computer couldn't get anywhere under 30ms round-trip (input + output) without stuttering horribly, but a different computer using the same interface was getting closer to 16, and I've since switched out audio interfaces and now can usually get around 11 unless I've got a lot of CPU or memory intensive software running.

share|improve this answer
    
Thanks! great thorough explanation. Lowering the buffer bar doesn't seem to cause any changes regarding latency... any ideas? –  Gal Margalit May 12 '13 at 11:00
1  
@GalMargalit My ASIO4ALL is rusty but I can't help but notice that in your edited-in screenshots, the A4A control panel and the M-Audio driver show 128 samples, but your DAW shows 512. Seems like your changes aren't recognized by your DAW yet. Do you need to save them somehow perhaps? –  Warrior Bob May 13 '13 at 14:57
    
It's exactly the problem (: it won't manage to set or save the whole piece together –  Gal Margalit May 13 '13 at 17:07
up vote 1 down vote accepted

Success: 10ms
Just needed to disable the onboard soundcard.
(In computer sound preferences, not in asio4all)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.